Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm logged in to my Debian machine using putty. I have a GNU screen session open and I am running vim in it. the problem I have is that when I go to save the file using :w<enter> this appears to translate to M<newline> in vim! The combination of these programs is doing it - if I just use vim without gnu screen then the problem goes away.

How can I prevent putty-gnuscreen-vim from translating the :w<enter> character sequence?

I looked at the putty settings and the only one that looks relevant is:

terminal > keyboard > the function keys > ESC[n~

I have tried changing this to linux and vt100+ but it has no effect on the problem.

also

$ echo $TERM
screen
share|improve this question
    
The first thing I ask people to check in this kind of situation is to make sure that their TERM environmental variable is set to "screen" within screen. If not, that's a problem and must be fixed. –  Heptite Dec 3 '13 at 0:33
    
i just checked. it is unfortunately. –  mulllhausen Dec 11 '13 at 12:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.