Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Oracle Virtual box (v 4.3.4 r 91027) installed on a Windows 7 x64 throws a Failed to attach USB device STMicroelectronics STM32 STLink[0100] to the virtual machine .. .. is busy with previous request..

share|improve this question
    
Can you provide the log file for Virtual Box? –  Ramhound Dec 2 '13 at 15:19

2 Answers 2

As I spent somt time googling the answer, here is what helped me out: https://forums.virtualbox.org/viewtopic.php?f=6&t=59303

share|improve this answer
1  
Welcome to SU. While your link might provide the answer it can quickly before outdated or removed. Can you include the main information from the link in which answers the question in your answer and provide the link as a source. Thanks. –  Matthew Williams Mar 31 at 7:42

Basically you have to add your device and a device filter.

  1. Install the "Oracle VM VirtualBox Extension Pack" to match your VirtualBox version. https://www.virtualbox.org/wiki/Downloads

  2. Connect your USB device.

  3. Confirm that you can also see your USB device via the VBoxManage list usbhost command. You cannot add a working Filter in VirtualBox until this is working.

  4. In VirtualBox, go to the Settings of your guest, USB section, and add a Filter for your USB device and a new device filter (empty).

  5. Start your guest and confirm that it can see your device.

(This steps I get from here: superuser.com/questions/306172/how-can-i-make-my-virtualbox-vista-see-my-usb-device-ipad)

Here the video that illustrates step by step, how I fix this problem: USB device is busy with a previous request

Credit to: youtube.com/user/tutorialnacional

share|improve this answer
    
Welcome to SuperUser. Please edit your answer to include the actual steps to fix the problem, such that when/if the linked article is no longer available your answer is still useful to others. You are still of course encouraged to give credit to the linked source. –  Twisty Nov 12 at 3:30
    
Edited and complemented –  Rubens Frss Nov 13 at 14:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.