Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Oracle VirtualBox (v 4.3.4 r 91027) installed on Windows 7 64-bit throws this error message:

Failed to attach USB device STMicroelectronics STM32 STLink[0100] to the virtual machine ..
.. is busy with previous request..
share|improve this question
Can you provide the log file for Virtual Box? – Ramhound Dec 2 '13 at 15:19

3 Answers 3

up vote 1 down vote accepted

Adding a device filter as mentioned by rubStackOverflow is necessary avoid the host OS using actual drivers for the device. If you got this right and watch the Windows Device Manager while plugging in the device, you see USB Controllers -> Virtualbox USB appearing instead of the actual device.

If then the device is not detected by the guest OS, check if the host Windows has an upper USB filter driver like USBPcap installed. (Reference:

  1. Start regedit.
  2. Find HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{36FC9E60-C465-11CF-8056-444553540000}.
  3. Look for a key UpperFilters. In my case it was there and had value USBPcap. Most likely this came from Wireshark or I may have installed it manually.
  4. Rename or remove the key UpperFilters.
  5. Reboot the host.
  6. Check the USB filter setting of the guest (generalize it by leaving everything clear except VID/PID settings).
  7. Start guest.
  8. Plug in USB device.
  9. Watch host device manager show Virtualbox USB.
    1. Watch guest device manager detect actual device.

Good luck!

share|improve this answer

Basically you have to add your device and a device filter.

  1. Install the "Oracle VM VirtualBox Extension Pack" to match your VirtualBox version.

  2. Connect your USB device.

  3. Confirm that you can also see your USB device via the VBoxManage list usbhost command. You cannot add a working Filter in VirtualBox until this is working.

  4. In VirtualBox, go to the Settings of your guest, USB section, and add a Filter for your USB device and a new device filter (empty).

  5. Start your guest and confirm that it can see your device.

(This steps I get from here:

Here the video that illustrates step by step, how I fix this problem: USB device is busy with a previous request

Credit to:

share|improve this answer
Welcome to SuperUser. Please edit your answer to include the actual steps to fix the problem, such that when/if the linked article is no longer available your answer is still useful to others. You are still of course encouraged to give credit to the linked source. – Twisty Nov 12 '14 at 3:30
Edited and complemented – rubStackOverflow Nov 13 '14 at 14:20

As I spent some time googling the answer, here is what helped me out:

I've done a lot of changes. I'm not sure what step did the fix.

I changed my VM a little bit, I moved it from C: to D:, and added a CPU in VirtualBox settings. Then I made a change in the Device Manager of the host machine. Yesterday I tried out the "Allow the computer to turn off this device to save power" of the "Power Management" of both Generic USB Hubs with no breakthrough, today I unmarked that again on both Generic USB Hubs. I also deleted parts of the USB Filter (but I tried that before many times) and finally I started my VM again.

After I inserted the USB device I got a notification from my host that it installed the VirtualBox driver! (I don't know if it installed it again?!) Then I could bind the USB device by right-clicking the USB icon of the VM window and selecting the device.

Yes, that was the problem, the VirtualBox USB driver was missing from Universal Serial Bus controllers. I don't know how, but I could bind a USB stick.

share|improve this answer
Welcome to SU. While your link might provide the answer it can quickly before outdated or removed. Can you include the main information from the link in which answers the question in your answer and provide the link as a source. Thanks. – Matthew Williams Mar 31 '14 at 7:42

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.