Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I need to mount a ntfs volume for read & write for a particular group of users, so I tried putting in this line in /etc/fstab: (I have also tried UUID but it was the same result)

/dev/sda1     /mnt/userdisk    ntfs-3g    uid=1001,gid=1001,dmask=0002,fmask=0003        0       0

Also, I tried the manual mount command with the option -o uid=1001,gid=1001,dmask=0002,fmask=0003

However, on both occasions, the result came out as the following without any of the options I supplied when I checked the mounted device (as well as in /etc/mtab):

 /dev/sda1 on /mnt/userdisk type fuseblk (rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096)

I have also tried using UUID instead of /dev/sda1, the "permissions" options instead

So it seems that somehow it always uses a default set of options. Could it be because of the fuse settings or the default script? Any idea how I get the options I need applied?

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.