Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've seen couple of sites that stream audio to my browser like SoundCloud and Grooveshark, but Firefox doesn't reproduce them in Linux. How can I reproduce these streams?

The console gets filled with messages like these:

[10:48:25.960] HTTP "Content-Type" of "audio/mpeg" is not supported. Load of media resource http://stream168a.grooveshark.com/stream.php?streamKey=874a8938966d8a9aa9bc33463bda8157749479a7_529df641_1a00e4e_2f578ed_fe2e2f8c_36_0 failed. @ http://html5.grooveshark.com/#!/now-playing
[10:48:25.961] "MEDIA_ERR_SRC_NOT_SUPPORTED" 
share|improve this question
add comment

1 Answer 1

up vote 5 down vote accepted

The problem is that Firefox doesn't include the MP3, MPEG, H.264, etc. codecs by default, hence it relies on the system's installed codecs, which in the case of Linux is GStreamer. Normally, Firefox is built with GStreamer support, but you should check the about:buildconfig page in case this is disabled.

To enable GStreamer you should visit the about:config page and look for the media.gstreamer.enabled key. Toggle it to enabled and restart Firefox. Congrats you have audio stream support.

Still doesn't play!

Now you should be getting:

[10:48:25.961] "MEDIA_ERR_DECODEC_NOT_SUPPORTED"  

or

[10:48:25.961] "MEDIA_ERR_NONE_SUPPORTED"  

This is because of two reasons:

  1. Firefox still doesn't offer support for GStreamer 1.0, so that you are able to reproduce in others players that uses GStreamer mpeg doesn't mean that you should be able too. Install the gstreamer plugins for 0.10 base/good/bad/ugly. In debian based distros should be:

    sudo apt-get install gstreamer0.10-plugins-base gstreamer0.10-plugins-bad gstreamer0.10-plugins-ugly gstreamer0.10-plugins-bad
    
  2. You are lacking some plugins. Make sure that you have the correct/complete plugins.

share|improve this answer
    
I'm running the firefox package for Fedora 19. My about:buildconfig has --disable-gstreamer in its "Configure arguments" section. How do I change it? (Besides that, there is no media.gstreamer.enabled key). –  That Brazilian Guy Dec 3 '13 at 17:11
    
@ThatBrazilianGuy check my link in chat ;). –  Braiam Dec 3 '13 at 18:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.