Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How do you grant read/write access to a mounted NFS filesystem on a remote server?

The user I want to have access has UID=1000 and GID=1000, so I tried mounting with:

sudo mount -t nfs -o _netdev,soft,intr,rw,bg,uid=1000,gid=1000 myserver:/data /mnt/data

However, that gives me an "Unrecognized mount option" error, implying my filesystem doesn't support the UID and GUI options. So instead, I successfully mounted it with:

sudo mount -t nfs -o _netdev,soft,intr,rw,bg myserver:/data /mnt/data

Yet that exposes all the files as being owned by nobody:nogroup.

Even if I use sudo chmod -R 777 /mnt/data to give everyone access, I still get a "Permission denied" error if I try to access the files with my normal user. How do I fix this?

I'm running Ubuntu 12.04.

share|improve this question
Does the remote mount have permissions correctly set, and do the userids match the local servers userids? –  Paul Dec 3 '13 at 22:51

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.