Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a MySQL server (XAMPP) running on my computer and I can't access it from the university wifi. It's working from my home, from my friend's home and on my cellphone (3G), but it just won't work from the university wifi.

Does anyone know why it's not working and how I can make it work?

I heard something about port tunneling, can this be used to solve my problem (or is it's lack causing my problem)?

share|improve this question
1  
You should reconsider having XAMPP accessible from outside your LAN, as it has several security features disabled and uses well know default passwords. –  Baarn Dec 5 '13 at 2:10
    
It is possible that the university wifi is blocking certain ports that is required for you to connect back to your computer. You can try setting up vpn at your computer and vpn yourself to your computer before accessing the server. Maybe consider changing the default port on the mysql server and see if you are no longer blocked on the university wifi. –  Darius Dec 5 '13 at 2:42
1  
If possible you can ask system administrator of the University about which ports are open and which are not. Also, try to ask him to help, because he knows the university network better than anyone else and probably he will be happy to help you. –  Nikolay Dec 5 '13 at 3:09

1 Answer 1

The open ports on public / shared wifi are generally limited to only a few. Most database ports are explicitly blocked, actually. And this is nearly always the case by default with most VPN's.

That said, here is an answer to your problem: an SSH Tunnel. Here's one way to do it: http://www.howtogeek.com/howto/ubuntu/access-your-mysql-server-remotely-over-ssh/

Google will help with many other approaches.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.