Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed SKydrive the other day but now when I log on my machine I get this error that says "skydrive can't be run using full administrator rights, please restart skydrive without administrator rights". I don't really want to setup a new account on my machine, and it was working as the skkydrive folder is fully sync'd. The machine has just been rebuilt and over 100 updates have been installed over the last two days so not sure if one of these updates caused the issue? the only account is the local admin account and i've tried with and without a password.

Anyone know how to get skydrive running?

enter image description here

share|improve this question
up vote 1 down vote accepted

You need to enable UAC to use SkyDrive.

share|improve this answer
UAC is enabled, I have tried in Default and the one below (screen doesn't go black). neither allow skydrive to work. – Purplemonkey Dec 5 '13 at 8:58
“the only account is the local admin account” there lies your problem. The buit-in Administrator account does not get UAC. – kinokijuf Dec 5 '13 at 15:52
Nice one that seems to work, I have created another Admin account and its fine. I created it first as a user, got severely annoyed by all my apps requiring admin rights, then saw your comment. upgraded that user to admin and Skydrive is still working. cheers. – Purplemonkey Dec 5 '13 at 19:01

Unfortunately, assuming that the error message is correct and that you as you say only have a local administrator account on the system, it won't work. One of them will have to budge and something tells me there is a reason why Microsoft won't let you run the SkyDrive software under a full administrator account. Running as local administrator on any sort of regular basis is severely discouraged because it opens up the potential for so many problems, including both an increased attack surface in case of software vulnerabilities as well as the risk of a user error causing a problem with the OS.

Alas, without creating a non-administrator account, I doubt it can be made to work.

share|improve this answer

I had the same trouble. Eventually I decided it was because I had a professional copy of windows 7, and OneDrive is designed for personal Windows users (with business customers using "OneDrive for Business"). Well, I didn't want to use OneDrive for business - it assumes you've got a lot of things going on which aren't necessarily going on when you're using Windows Professional for home use.

How I fixed it -

  1. Go into start and click "all programmes."

  2. Find the "OneDrive"

  3. Right click on Onedrive and selected "properties"

  4. Click to "compatibility" and in the drop-down bar select "Windows 7"

  5. Click "apply"

  6. Run the installer again

PS. The user mentioning you need to have UAC on is correct, but you will find your UAC is on by default in Windows 7 and therefore is not the issue here. It being off caused problems in Vista, and turning it on was the solution then - this is the solution I found worked for me in Windows 7.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.