Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

One of things I loved about VMware Fusion 2 was the ability to have 6/7 vms running in different virtual spaces and being able to switch between them using the space overview button in Mac OS X. However, space support in VMware Fusion 3 seems to be completely broken. If I move a particular VM into a space then I find that all the VMs are now in that space!! How have they managed to break it so badly, I would have thought this was fundamental. Does anyone know a work around?

P.s I'm using Leopard not Snow Leopard if that makes any difference.

share|improve this question
add comment

3 Answers 3

up vote 1 down vote accepted

Potential Fix to allow moving WinXP screen from one monitor to another... under the control of VMWare Fusion 3 and OSX Snow Leopard "Spaces"

  • LapTop Config: MacBook Pro, OSX 10.6.2 Snow Leopard, WinXP with VMWare Fusion 3 (JUST upgraded from VMWF2)

  • Display Config: Two monitors: one UP (stand alone), one DOWN (integrated into laptop). Both are 1440x900 pixels.

  • Problem: After upgrading from VMWF2 to F3, WinXP started running in FULL SCREEN mode on the DOWN monitor. I needed to move it to the UP monitor but the old way of doing it did not work any more.

    (Note: With VMWF2, I could open SPACES, then drag/drop the WinXP image into the UP monitor "space"... and that's where it ran. Life was good.)

    After the VMWF3 upgrade, the drag/drop approach no longer worked. A google search brought me here.

  • My Fix:

    1. Change VMWF3 "View" from FULL SCREEN to SINGLE WINDOW.
    2. Open SPACES and drag the VMWF3 app (ex: WinXP image) to the desired SPACE (UP).
    3. Close SPACES and verify app is running where desired.
    4. Click the FULL SCREEN icon in the upper right corner of the VMWF3 app display area to revert to FULL SCREEN mode.
    5. From then on, the VMWF3 app (ex: WinXP) runs in the desired monitor (UP).

Hope this helps some... JM

share|improve this answer
    
Yes this does work doesn't it. My colleague has been doing this. Still, I wish they'd actually fix it... Sorry I don't have the rep to +1 on superuser (wish rep was held in common with stackoverflow) –  Benj Dec 11 '09 at 11:48
add comment

For what is worth, this does not happen on Snow Leopard. I’ve just tried it.

note: I know you’re running Leopard.

UPDATE: after what you posted, I tested this:

I have two screens with different resolutions (1440x900 on the left and 1280x1024 on the right). I use 2 spaces (up and down) which in turn consist of those two “screens” each. I opened an XP, Vista and Ubuntu and placed them Full Screen like this:

SPACE 1:    VISTA || UBUNTU
           -----------------
SPACE 2:    empty || XP

When dragging UBUNTU to the empty space, it will move (always pressing F6 to open spaces overview), but when I exit F6 mode, UBUNTU sits on TOP of XP, which is a bug.

When dragging VISTA to the ‘empty’ space, it will stay there. This is ok. And it probably works because it’s the same “left” screen.

Apparently the different resolution between both screens, causes VMware to fail placing the VMs if they are FullScreen.

I didn’t see the issue of all VMs going to the same space if one was dragged.

Hope this helps.

share|improve this answer
    
Well, that's good to know. Thanks! –  Benj Nov 10 '09 at 17:22
    
I'd +1 but sadly I don't have enough rep ;-) –  Benj Nov 10 '09 at 17:23
    
I have enough rep; here's a +1 for you. :) –  osij2is Nov 10 '09 at 18:45
    
Hmm, I've just discovered that Fusion 3 does work with spaces on Leopard if the VMs are not full screened. However, I like to work with full screen VMs and that was always fine with Fusion 2. When you tried on Snow Leopart was that full screen? –  Benj Nov 11 '09 at 10:23
    
No, but I’ll try it tomorrow and report back ;) –  Martín Marconcini Nov 12 '09 at 0:03
show 2 more comments

I 'm having problems, too with Fusion 3 and Spaces in Leopard. It is definitely related to running in Full Screen, which is the only way I like to use it. I had been a beta tester on Fusion 3 and got so frustrated with its behavior in Spaces that I gave up and went back to version 2. I had hoped they'd fix it before it was released out of beta.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.