Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This worked in Leopard, although since Snowie came along …

I have a Location setup with a DNS server to use [eg 10.0.0.17] , and a search string [eg sub.dom.ain.com]

In the terminal:

$ nslookup cake
Server 10.0.0.17
Address: 10.0.0.17#53

Name: cake.sub.dom.ain.com
Address: 10.0.0.38

So works like a charm. Although if I just the hostname cake in any other application within OSX - such as Safari/CoRD, they simply can't resolve the hostname. I have to instead use the FQDN cake.sub.dom.ain.com - why is this so? Why did this work in Leopard and is now broken?

Would love a solution.

Thanks

share|improve this question
add comment

3 Answers

Justin was onto the right idea here, but didn't carry it to the finish line:

In Advanced » DNS, add your sub.dom.ain.com to the Search Domains, and your problem will be solved.

share|improve this answer
add comment

This may not be relevant, but I had a problem when I upgraded where having a custom DNS server in my network settings prevented it from using the DNS servers specified in DHCP from my ISP.

share|improve this answer
add comment

When I checked my DNS settings, I noticed that under Advanced there is a Search Domains area, which appears to be blank by default.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.