Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This worked in Leopard, although since Snowie came along …

I have a Location setup with a DNS server to use [eg] , and a search string [eg]

In the terminal:

$ nslookup cake


So works like a charm. Although if I just the hostname cake in any other application within OSX - such as Safari/CoRD, they simply can't resolve the hostname. I have to instead use the FQDN - why is this so? Why did this work in Leopard and is now broken?

Would love a solution.


share|improve this question

Justin was onto the right idea here, but didn't carry it to the finish line:

In Advanced » DNS, add your to the Search Domains, and your problem will be solved.

share|improve this answer

This may not be relevant, but I had a problem when I upgraded where having a custom DNS server in my network settings prevented it from using the DNS servers specified in DHCP from my ISP.

share|improve this answer

When I checked my DNS settings, I noticed that under Advanced there is a Search Domains area, which appears to be blank by default.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.