Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am the recent owner of a new Levono Yoga 2. The specs of this are:

  • 4th Generation Intel Core i7-4500U Processor (1.80GHz 1600MHz 4MB)
  • Intel® HD Graphics 4400
  • 8.0GB PC3-12800 DDR3L SDRAM 1600 MHz
  • 512GB SSD

It's a great bit of kit. However I am having problems running VMware and/or VirtualBox.

I am trying to run Ubuntu 13.10, but the guest OS seems so so slow. Not just the GUI, which I sort of understand at very high resolutions, but the actual speed of it overall. For example, running: rails s which starts a Ruby on Rails web server takes around 10-15 seconds to load, while running this on my other Ubuntu laptop takes less than a second. Lots of other tasks also seem to take a long time.

These are the things I have tried:

  • Switched from 1 processor to 4 and all the ones in between.
  • Uninstalled local graphics driver to default to Windows driver, and tried all resolutions.
  • Made sure that Unity / Gnome are using 3D acceleration and they are.
  • Switched dynamic hard drive to fixed allocation and all different filesystems.
  • Tried all Virtualization Types.
  • Enabled / Disabled Virtualization in BIOS.
  • Changed memory from 1GB to 4GB and back again.

I am using the 64-bit Ubuntu, and I have set VMware to 64-bit and 32-bit, but it is still the same. I have tried all similar options in VirtualBox too.

I am a bit stuck on this one. I cannot see any more options to change.

share|improve this question
1  
It's a dual core CPU clocked at 1.8GHZ, it's not exactly a powerhouse, open up the task manager and take a look at your CPU usage, I would imagine the overhead of Virtualbox combined with running Ubuntu might would taxing. –  Slowki Dec 5 '13 at 18:47
    
Yeah I did think this, and I tested again to confirm but with Ubuntu running, and then running the "rails s" process I reach 20% CPU Utilisation. So there is a lot of room in there! Its bugging me! –  Charlie Davies Dec 6 '13 at 10:11
    
I see you are using Windows 8.1, why not try the already build-in Hyper-V. I run Ubuntu 13.10 in Hyper-V and it is fast. Also try to install some other Desktop Environment for Ubuntu like Xfce which is very resource friendly. –  Devid Dec 19 '13 at 10:57

protected by Community Jan 19 at 6:25

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Browse other questions tagged or ask your own question.