Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My current Windows 7 is in English. I have some files transferred from another computer which contains non-english characters. Look at the picture below

enter image description here

Now, I want to delete them all. But writing this character in search box doesn't give the desired files.

enter image description here

How can I delete all the files which includes non-english/non-word characters?

share|improve this question

3 Answers 3

up vote 2 down vote accepted

Cihad, PowerShell is probably your best bet here.

I did a little test to find all non-English chars in a folder using the code below

Get-ChildItem c:\TurkishFileNames\ | where-object {$_.name -match "[^\x00-\x80]+"}

That returns all those non-english file names. You can then pass them to remove-item, but first establish that you are getting the correct names. One wrinkle here is you were talking about 'folder' names, and I tested this with file names.

Still, I believe you can use the same trick. If you have PowerShell 3.0 or 4.0 installed, you can use -directory to display only folder names when using Get-ChildItem:

Get-ChildItem c:\TurkishFolderNames\ -directory

The rest is going to be similar. You can download PowerShell 3.0 or 4.0 from Microsoft

http://www.microsoft.com/en-us/download/details.aspx?id=34595 (WMF 3.0)

http://www.microsoft.com/en-us/download/details.aspx?id=40855 (WMF 4.0)

Windows 7 came with PowerShell 2.0, if you will stick with that you can still use the old syntax to get directories only:

Get-ChildItem C:\TurkishFolderNames\ | ? {$_.PsIsContainer -eq $true}

You can then proceed with the rest:

Get-ChildItem C:\TurkishFolderNames\ | ? {$_.PsIsContainer -eq $true} | ? {$_.name -match "[^\x00-\x80]+"}
share|improve this answer
    
That's cool. Actually you forgot to say -r :) also I needed to write characters one by one like [\xb1\xc4] –  Cihad Turhan Dec 5 '13 at 21:09
1  
Well, I did not mean the examples to be literal. I have no idea how your folder structure looks. If it is hierarchical, then sure, throw -recursive in there. –  Adil Hindistan Dec 5 '13 at 22:33

As taken from my good friend Adam here: Can't search by dollar amounts that are in filename.

You may need to wrap your search in the following way:

~="searchterm"

share|improve this answer
    
Unfortunately, it doesn't retrieve any results. If you read the comments below on your link, they already commented this method is not working in anyway. –  Cihad Turhan Dec 5 '13 at 20:12
    
The method works, however it did not work for that particular user. I have tested it, and it does work. In your case though I'm not sure what the issue would be... –  Michael Frank Dec 5 '13 at 20:15
    
I'll try to find solution on this. Most probably that character belongs to another language so that makes problem. Thanks for the tip. –  Cihad Turhan Dec 5 '13 at 20:17

A fast way to find files with a specific character is Powershell

dir D:\* -r -include *∓*

You can also use unicode notation: 0x2213 is equivalent to U+2213

$char = [char]0x2213
dir D:\* -r -include *$char*

Btw. using the Windows search does give me correct result with your special characters!
Are you sure you haven't misconfigured something? (My config)

enter image description here

share|improve this answer
    
Tried, still gave me no results :( It's probably because of encoding. Is there any way to search explicitly define a character like U+2213 –  Cihad Turhan Dec 5 '13 at 20:45
    
@CihadTurhan and now? :) –  nixda Dec 5 '13 at 21:36
    
Command line unicode works thanks. I tried Adil's answer already. Well, that's interesting. When I write in search box like yours I can't find that any result. I believe it's because that combination of ∓, ÿ etc represnts other characters like ş,ı,ö so it can't find. –  Cihad Turhan Dec 5 '13 at 21:43
    
@CihadTurhan I use partial matches and disabled search index. Maybe thats the cause? Can I have your example where it doesn't work for you? –  nixda Dec 5 '13 at 21:44
    
Unfortunately not :( I believe it's a language problem. When I type ÅŸ it finds for example ayrac.png but not sÅŸra.png. Thanks for your effort. I'll go with command line. –  Cihad Turhan Dec 5 '13 at 21:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.