Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Does anyone know what can I do to resolve intermittent connection lapses while listening to music via my Airport Express?

I've tried everything short of buying a stronger wireless router, but it still loses the connection for a few seconds every once in a while.

Thanks!

KA

UPDATE:

I'm actually not using a base station - I'm using a PC (win7)

I did solve the problem last weekend - I took the easy way out and bought a much stronger, newer linksys / cisco n-band extended range wireless router. I replaced a 5-year old d-link on an older band. My AE no longer loses the connection, and I have 3 bars of reception on my iPod touch where I used to have one on a couch on the main floor.

Thanks for those who answered!

KA

share|improve this question
add comment

4 Answers

up vote 1 down vote accepted

You could try using a wireless stumbler, such as KisMAC, that shows the signal strengths and channels of any wireless signal it can receive. This will let you figure out the best channel to set to. Keep in mind that channels overlap, so 1, 6 and 11 are the three big ones to aim for (these particular channels do not overlap). If you can't find a good channel (this will only work if you have a newer base station) you could also try switching the band to 5GHz. There will be less range, but there are few devices on this band.

Another thing you could try is repositioning your router. Try attaching an extension cord (or the replacement extension duck connector that comes with Mac laptops. I don't know if the Express comes with one) and repositioning it away from sources of interference.

share|improve this answer
    
In my case, the signal is very strong (2m from AE) but I still experience the problem. It's not always signal-strength related. –  Michiel de Mare Sep 29 '10 at 20:34
add comment

It seemed to have greatly lessened (but not disappeared) when I switched from 802.11N (B/G compatible) to N only (2.4GHz). However, many devices don't support 802.11N (including older iPhones).

Edit: The problem is still here on my old Macbook Air (after a software update around the time Snow Leopard came out, can't remember exactly). My iPad, which can use AirPlay with the 4.2 beta also skips, so I was almost certain that the problem was with the AE, and was considering replacing it. But my new Macbook Air hasn't got the problem (so far, fingers crossed).

So I'm stumped. Is it a defect in the AE? Then why can my new laptop play music without problems? And why was the problem introduced with a software update?

Or is it a problem with the laptop? But why does my iPad have the same problem? And why doesn't my new laptop, with identical versions of iTunes and OSX, and identical settings?

Edit: Ok, it still skips on the new Macbook, but much less frequently as on the iPad. I'm going to try replacing my AE next, keep you updated.

share|improve this answer
add comment

I had a similar problem, but with an iTunes update in the past few months, the problem seems to have disappeared.

If an update doesn't help, then set itunes to play through multiple speakers, (including the computer it's playing from) that may solve the problem. You can mute the volume on your computer if you don't want tinny sound adding itself to the music coming through your sound system.

share|improve this answer
    
That only means that the airport speakers fall silent for half a second every now and then, while the computer speakers play on. –  Michiel de Mare Sep 29 '10 at 21:10
add comment

I have a mac mini, an airport express and a Wii in the same room and had the same problem. Then I assigned the channel of all routers in the house manually and the problem is now gone.

Could mixed Draft N and b/g be part of the problem? Because I changed it to fixed b/g when I set the channel of the respective router.

share|improve this answer
    
I'm using N only, and I have the problem. –  Michiel de Mare Sep 29 '10 at 20:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.