Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to install Ubuntu (64 bit) as a guest operating system in VirtualBox. My setup is an Intel i3 machine with Windows 7 (64 bit) and VirtualBox 4.3.4r91027 (latest version). I went through the setup wizard to create a new virtual machine, but when I try to boot Ubuntu it complains that it doesn't have an x64 CPU.

Per results of a Google search, I checked settings for VT-x/AMD-V (already enabled) and I/O APIC (enabled it but same result).

What am I missing?

share|improve this question
1  
Information about the host hardware is required. Did you select Ubuntu 64-bit ( or can you select any 64-bit version ) when you created the virtual machine? This problem normally comes from the fact you have Hyper-V installed. Have you made sure that Windows actually knows your virtualization extensions are enabled? –  Ramhound Dec 6 '13 at 12:29
    
@Ramhound Ah! the relevant setting is the version 'Ubuntu (64 bit)' when creating the VM, I hadn't noticed because it defaulted to plain 'Ubuntu' based on the VM name. Works now, thanks! –  rwallace Dec 6 '13 at 12:36
1  
@rwallace yeah, i used to burn myself too with this. If creating the machine and naming it something with 64 in it, it will default to 64bit. Otherwise you need to select it yourself. (If you named it Ubuntu (64bit) from the beginning it would have defaulted to 64bit but i guess you just named it Ubuntu:) –  Rik Dec 6 '13 at 12:46
    
@rwallace - Feel free to answer this question yourself. I won't do it because my comment is based on multiple existing answers on this very website. –  Ramhound Dec 6 '13 at 13:26
add comment

1 Answer

I created my virtual machine when VT-x was disabled in BIOS. So what happened is, it only let me pick non x64 OS versions. I tried to boot the x64 image and got an error about VT-x not being enabled. Went in to BIOS and turned it on (why is the default off Asus?!). Tried to boot again and got another error. After reading this post I went back into the settings and saw that the OS version drop down now included x64 entries. After selecting one of those, it booted right up.

share|improve this answer
    
It's off by default for security reasons –  Canadian Luke Dec 27 '13 at 23:13
    
Can you elaborate? I assume so that some rouge boot loader can not root the box? Seems unlikely, especially with secure boot. –  jfrodsham Dec 27 '13 at 23:29
    
I don't know the specifics of it, but remember that Secure Boot is only ONE avenue of safety (if you are only talking about those attacks). But I was simply told that was the issue, so that's what I went off of. Intel disables it by default on desktop boards as well –  Canadian Luke Dec 27 '13 at 23:31
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.