Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Since I must use also VMWare I need to temporarily turn off Hyper-V

In Windows 8 I used

bcdedit /set hypervisorlaunchtype off

to disable hypervisor, and:

bcdedit /set hypervisorlaunchtype auto

to re-enable it.

In this way, after a normal reboot, VMware see Hyper-V as disabled and works fine

Unfortunately in Windows 8.1 using this command, VMWare doesn't start because see Hyper-V as enabled and I must use

dism.exe /Online /Disable-Feature:Microsoft-Hyper-V

and

dism.exe /Online /Enable-Feature:Microsoft-Hyper-V /All

This, unlike the previous way, doesn't simply turn-off Hyper-V, but disable the whole functionality that every time is unistalled and reinstalled.

Is there any other way to switch off-on Hyper-V without using dism?

share|improve this question
1  
On 64 bit Windows, the command bcdedit can be found in %WINDIR%/Sysnative, for those of you having trouble locating it. See superuser.com/a/886278/209016 – Manuzor May 19 '15 at 7:25
    
You can use Hyper-V Switch to automate the task of toggling Hyper-V and rebooting. I've made this little tool and it works on my Windows 10 computer. – ygoe Apr 25 at 18:14
up vote 7 down vote accepted

The problem was caused by a setup corruption occurred after the upgrade, reinstalling both VMware and Hyper-V, the solution to disable and re-enable the Hypervisor launch, still works.

share|improve this answer

With Windows 8.1 and VMWare Workstation 10.03 you can use both Hyper-V and VMWare except I suspect you are not getting full virtualization under VMWare. It will only let you run 32-bit VMs with possibly other limitations.

Turning it off through boot entry allows you to run 64-bit VMs again without uninstalling the Hyper-V feature. Either the hypervisorlaunchtype setting being on off or Auto there were no messages about Hyper-V in VMWare.

share|improve this answer

WARNING: When I disabled the hypervisor using bcdedit OR dism on Windows 10, the PC would no longer shutdown or sleep after the next reboot. So if you encounter this problem you may be forced to reenable it.

[Edit: I determined my problem was due to Hybrid Sleep no longer working for whatever reason. Having the hypervisor disabled or uninstalled allowed my PC to use Hybrid Sleep which wasn't working. Disabling Hybrid Sleep in Power Options fixed my issue and allowed me to keep the hypervisor disabled.]

share|improve this answer
1  
I use Windows 10 without any problem with the command. There is some other system problem or misconfiguration in your pc. – Silverstorm Dec 12 '15 at 20:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.