Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been struggling with a problem for a few days now, and hope some of you can help me out. I'll just explain what happend breifly.

Well, I have an AMD E-350 APU HTPC, which I use for media center stuff. A couple of days ago I decided to install XBMCbuntu on it, as I thought learning Linux could be fun. I ended up having so much trouble with sound driver, graphics driver, hardware acceleration not working and so on, that I decided to reinstall Windows again. So I popped in the Windows DVD, formatted all "visisble" partitions, and installed Windows on the same drive as Linux used to be on.

When the installation reached the reboot part, the computer shutdown and the started up and gave me the message:

Loading Operating System ...
error: unknow filesystem.
grub rescue>

Now I don't know much about bootloaders nor Linux to be honest, but I thought it might have been some ext partition which I didn't format when I reinstalled Windows, so I went into an Ubuntu Live CD, opened gparted and left everything as unallocated space. Then I restarted the Windows installation, but same problem occured again.

At this point I've been googling pretty much non-stop, and I've pretty much lost track of what I've tried and what i haven't. I've run pretty much any imagineable bootable, GRUB/boot recover CD and still no luck :(

Here's a link to an Ubuntu Pastebin, I've got from one of the many attempted rescues, maybe it can help?: http://paste.ubuntu.com/6531541/

And please note that i'm fully aware that there's lots of people with a similar error on this page, and on google in general, but i've really tried almost anything that has been suggested in any of those threads, so i really hope you'll forgive me starting a new question.

Thanks a lot.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

You left GRUB (the bootloaded installed by ubuntu) installed. To fix, do this:

  1. Boot your windows 7 DVD again, and once you've booted it, go to 'repair your computer'.

  2. Click the bulletpoint for "use recovery tools", then click 'next'.

  3. Click "command prompt."

  4. In the command prompt, type bootrec.exe /fixmbr

  5. Once bootrec is finished, restart your computer. It should work now.

However, I really recommend you give linux a chance and fight with it for drivers. I have a lot of trouble with wireless drivers, but once I fixed them, linux is a far superior OS. Anyway, there's your answer. It worked for me when I tried last.

If that doesn't do it, boot into linux one last time from a live USB or DVD, and in a terminal type first mount to find what device your hard disk is seen as (example: /dev/sdb). Then, type sudo dd if=/dev/zero of=<hard disk device>. This will TOTALLY ERASE all data on the hard disk, so BE CAREFUL!

Anyway, that should delete the MBR as well.

share|improve this answer
    
Thanks Wyatt, but i already did that like a million times, and with commands like bootrec.exe /fixboot too. –  Martin Dec 7 '13 at 12:33
    
@Martin If you still need this fixed, I'd boot linux one last time in a live USB, and if you don't have anything on the hard disk that you need saved, do first mount to find what your hard disk is mounted as, then do sudo dd if=/dev/zero of=/dev/<what device your hard disk is>. This will completely zero out your hard disk, including the MBR. Then, GRUB will be gone. I added this to my answer. –  Wyatt8740 Dec 7 '13 at 18:56
    
I ended up reinstallaing a Linux distro again. I spent a day or so fighting the drivers, but they're working relatively good now, so i'll probably just stay with linux. Thank you for helping. –  Martin Dec 11 '13 at 16:07
    
Glad things worked out for you. Linux is really a great kernel, with a great OS. but driver support was always a pain on my lenovo g550 laptop (it used a broadcom 4312 wireless chipset, with no open source, free drivers). Once drivers work, it's smooth sailing. –  Wyatt8740 Dec 11 '13 at 16:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.