Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just installed Ubuntu on my T430s. I installed it by creating a partition, disabling Secure Boot, and then booting from a USB that contains Ubuntu's ISO.

Now when I boot up my laptop, Ubuntu's grub boots Ubuntu by default. Even if I interrupt grub and try to choose Windows Loader from the menu, it fails with the following two errors:

error: unknown command `drivemap`.
error: invalid EFI file path.

Press any key to continue...

I don't care about repairing these errors because I can still boot Windows by interrupting the initial boot screen with F12 and then selecting Windows Boot Manager from the list of options, which includes both "ubuntu" and "Windows Boot Manager".

But I do want to have Windows boot by default and only boot Ubuntu when I interrupt the boot screen with F12. Could someone please tell me how to achieve that?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

The solution in my case was very simple. All I had to do was go into the BIOS setup and find the Boot menu and change the order of boot items. I put Windows Boot Manager before Ubuntu and now things work fine. :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.