Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

A friend of mine came to me with a french Windows XP where windows had decided that keyboard would now be english-US keyboard instead of french keyboard.

After a few attempts, I came to the strange conclusion that it's impossible to change it. Whatever keyboard configuration I apply, the language dialog does not complain but sticks to the english-us keyboard.

I tried :

  • setting two keyboards, with FR as default
  • setting two keyboards, with EN-US as default
  • one keyboard as FR

It's like it was impossible to apply a new keyboard configuration. Any idea what could be wrong ?

share|improve this question
    
1 Do you have administrator privileges? 2 Is it a notebook with "special" keyboard settings tools? – Gerd Klima Nov 10 '09 at 16:23
    
The user has administrator privileges yes. I did not see any special keyboard setting tool but I will have a second look. – Bluebird75 Nov 12 '09 at 9:38

Follow these steps, it should get the job done.

Step 1 : In Device Manager, expand Keyboards, and then double-click the keyboard device. By default, this is Standard 101/102-Key or Microsoft Natural PS/2 Keyboard.

Step 2 : Right click and then click Update Driver.

Step 3 : Click Browse my computer for driver software, and then click Let me pick from a list of device drivers on my computer.

Step 4 : Click to clear the Show compatible hardware check box, and then click French PS/2 keyboard.

Step 5 : Click Next, click Yes if you receive an update driver warning message, and then follow the remaining steps to update the keyboard.

Step 6 : Restart the computer.

share|improve this answer

Step 1: Open Control Panel.

Step 2: Click "Date, Time, Language, and Regional Options".

Step 3: Click "Regional Options".

Step 4: Click "Languages", then "Details".

Mess around with the settings in there.

No administrator rights required.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .