Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I wasn't sure what the best stack exchange site was for this question, hopefully this works.

I'm trying to set up a home linux server (running arch linux arm on a raspberry pi), and I can't seem to get my windows desktop machine to recognize it via hostname (in this case "whitey"). I have it set to a static IP in my router (at 192.168.1.254), and (in theory), my router is functioning as a DNS server. When running "ping whitey" on windows, I get

Ping request could not find host whitey.  Please check the name and try again.

However "ping 192.168.1.254" works. What's curious is that both my linux laptop and, curiously, a linux virtual machine running on the windows PC can find my server (using "ping whitey"). This leads me to believe that the issue lies on the windows side, and not with the router or the server.

Any ideas? I've tried

ipconfig /flushdns

as well as manually setting my router as the dns server for ipv4 addresses.

Please let me know if more information is necessary...my networking-fu is not the greatest, so I'm not sure what would be helpful here.

Thanks for any help you guys can give!

share|improve this question

migrated from serverfault.com Dec 8 '13 at 16:48

This question came from our site for professional system and network administrators.

    
Thanks for migrating this, unnamed moderator. –  Hounddog Dec 8 '13 at 16:50
    
What gives you hostname whitey on a Windows cmd ? How did you configure your router to act as DNS server ? –  Levans Dec 8 '13 at 17:20
    
@Levans I'm not sure what the first part of your question is asking. Windows can't find "whitey" in any aspect. As to the second part, I didn't need to do anything special...as far as I can tell my router does it automatically if I turn on DHCP and I don't specify a different DNS to use. –  Hounddog Dec 8 '13 at 17:41
    
I meant, what is the output of the command nslookup whitey in a windows CMD ? (sorry, I mixed command names) –  Levans Dec 8 '13 at 17:55
    
Output is: Server: router.asus.com Address: 192.168.1.1 *** router.asus.com can't find whitey: non-existent domain –  Hounddog Dec 8 '13 at 17:58
show 1 more comment

1 Answer

up vote 2 down vote accepted

Windows uses DNS to resolve FQDN names - host1.contoso.com for example.

In your case whitey is NetBios name and DNS have no (and shouldn't have) knowledge of it.

I'm not a linux expert, but as far as I know your linux server needs samba in order to be able to broadcast its NetBios name across windows machines

share|improve this answer
    
Installing samba solved it! Thanks!! –  Hounddog Dec 8 '13 at 17:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.