Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to get Eudora to work smoothly under Windows 7. I know it is obsolete, but I have specialized filters and Perl scripts that are not portable to other email clients.

When Eudora starts in Windows 7, it displays the error dialog "Could not install Eudora MAPI because MAPI.DLL and/or MAPI32.DLL could not be renamed", followed by the error dialog "Eudora was unable to update the system registry. Your default mail program was not changed.".

This article says that Eudora needs to be the default mail program in order to prevent this error. In Windows 7, Eudora is not listed as an option in the list of default programs. There is no option to add any new programs. Other articles on how to add a new default program suggest adding a file type association for the new program. However, Eudora is already associated with the .MBX file type, but it still is not available on the Default Programs list.

This question says applications need to "register", but the answers (and the linked MSDN article) do not explain how that is done.

How can I make Eudora the default mail program under Windows 7?

share|improve this question
add comment

2 Answers

up vote 4 down vote accepted

I finally got it to work for me. The problem with Windows 7 is that the registry is finally protected. Eudora (by default) doesn't run privileged, and therefore can't change the registry. But it also doesn't set up the hooks that Windows 7 needs to know it can be set as a default mail program. [For some strange reason, MAILTO isn't listed as a protocol either - which means that you can't use that method.]

The solution is to right click on the Eudora.exe program icon and select "Run as administrator." You will then need to okay that when the UAC prompt asks if it's okay.

Eudora will complain as it starts about not being the default. Tell it it's okay to make it the default. It will then continue to start normall.

After that, it should no longer need any special privilege, but it will work correctly, not complain, and it will be launched as it should be anytime you click on a Mailto: link in an HTML page.

share|improve this answer
    
This procedure solved the registry problem. I don't need MAPI integration so I solved the MAPI problem by changing the "USE MAPI" settings in Eudora Options to "Never". I think Steve's suggestion would work also, and I may try it at some point. –  tim11g Dec 22 '09 at 20:49
    
The only remaining issue with Eudora under Windows 7 is the failure to connect when the program is first opened. The task window sticks on "Logging in" for a full minute, then times out. After that first failure, checking mail works fine. A minor issue, but does know of a solution? –  tim11g Dec 22 '09 at 20:51
add comment

There are two questions being asked here

  1. How to make Eudora the default mail client in Windows 7
  2. How to fix the error message - When Eudora starts in Win7, it displays the error dialog "Could not install Eudora MAPI because MAPI.DLL and/or MAPI32.DLL could not be renamed", followed by the error dialog "Eudora was unable to update the system registry. Your default mail program was not changed.".

==

Answer to Q2.

I had to grant myself permission to the mapi.dll and mapi32.dll files and then run the sweudora.exe program (which sets up Eudora mapi setting). Here is how:

1 Open an administrator command prompt by typing cmd into the start menu search box, and hit the Ctrl+Shift+Enter key combination. 2 To take ownership of the files, you’ll need to use the takeown command.

3 takeown /f C:\Windows\System32\MAPI.DLL

That will give you ownership of the files MAPI.DLL, but you still have no rights to delete or modify the permissions of it.

4 Now run the cacls command to give yourself full control rights to the file: cacls C:\Windows\System32\MAPI.DLL /G geek:F

Note that my username is geek, so you will substitute your username there.

5 Repeat this procedure for MAPI32.DLL 6 Now run sweudora.exe program

share|improve this answer
    
Steve, I was going to try this on another machine. At least on Windows 7, there is no file named MAPI.DLL in the C:\Windows folder structure. MAPISTUB.DLL and MAPI32.DLL are present in C:\Windows\System32. So I just repeated my procedure of setting Eudora / Options / MAPI to "Use Eudora MAPI Server - Never". That seems to solve all the problems except the failed connect (timeout) the first time it checks mail after starting. –  tim11g Jan 3 '10 at 22:49
add comment

protected by Diago Nov 9 '10 at 10:19

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.