Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Since going to Mavericks, I've lost the ability to use the clipboard in vim when run under tmux.

I install vim via brew. For reference, yes, the +clipboard option is definitely set.

When I run vim inside a terminal directly, I can access the system clipboard normally via * and +. But when running vim inside tmux, no such luck. I also have clipboard support turned on in tmux, so perhaps this is part of the problem.

For reference:

  • vim 7.4.52
  • tmux 1.8

In my .tmux.conf:

set -g set-clipboard on

Nothing is set in my .vimrc to explicitly turn on support. However, I'll note that adding the usually recommended option (which I've never needed before):

set clipboard=unnamed

has no effect.

share|improve this question

1 Answer 1

up vote 5 down vote accepted

Are you running into the problem that https://github.com/ChrisJohnsen/tmux-MacOSX-pasteboard solves?

share|improve this answer
    
Yep, that was the problem. Somehow, despite being installed, set-option -g default-command "reattach-to-user-namespace -l zsh" had gone missing from my .tmux.conf. –  G Gordon Worley III Dec 11 '13 at 20:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.