Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Config:

  • win7 x64 notebook
  • TL-WR1043ND hw rev V1 fw 3.13.13 (afaik latest)
  • cisco vpn 5.0.07.0290

Worked like charm until today. Suddenly it became unstable: whenever I try to transfer something 5+M. Of course, VPN breaks. Afterwards notebook still can communicate with router but not beyond (WAN). Workaround is to reboot router.

Problem seems to have started upon first DHCP renewal of router (as client) at ISP (as server) but neither reboot of cable modem nor reboot of router solved the issue.

Same problem seems not to be present if I transfer same files without cisco vpn. Previously it happened with another win7 notebook but without cisco vpn and it was not so persistent (maybe one reboot per week). Now it is (reboot every couple minutes => useless)

Assume it's incompatibility between router/cisco vpn or maybe router/win7 but which party is responsible? And especially, is there a cure?

(edit) when this occurs notebook can access admin gui of router but other functions like dhcp renew or dns lookup all fail. According to router log it receives "DHCP INFORM" but does not send "DHCP ACK". According to wireshark, however, router does send "DHCP ACK".

(edit2) seems that there's another player: problem happens only if traffic is generated by a vmware virtual machine (using NAT between host and guest)...

(edit3: the solution) It was caused by Cisco using UDP which made TP-Link DOS "Enable UDP-FLOOD Filtering" to kick in and block the notebook's IP completely.

Relevant settings in Cisco VPN: Modify / Transport / IPSec over TCP (instead of IPSec over UDP).

Relevant settings in TP-Link: Security / Advanced Security / Enable UDP-FLOOD Filtering.

Workaround in same place: click "Blocked DoS host list" and then click "clear" if you find your IP inside.

(lacking reputation I can't close my own question; pls do it)

share|improve this question
    
Found solution! it was caused by Cisco using UDP which made TP-Link DOS "Enable UDP-FLOOD Filtering" to kick in and block the notebook's IP completely. Relevant settings in Cisco VPN: Modify / Transport / IPSec over TCP (instead of IPSec over UDP). Relevant settings in TP-Link: Security / Advanced Security / Enable UDP-FLOOD Filtering. Workaround in same place: click "Blocked DoS host list" and then click "clear" if you find your IP inside. Someone with appropriate rights could please close this question (I need no score for answering my own questions ;) ) –  Surranó Dec 10 '13 at 19:20
add comment

migrated from serverfault.com Dec 11 '13 at 11:28

This question came from our site for professional system and network administrators.

1 Answer

up vote 0 down vote accepted

(now trying to close it for real!)

It was caused by Cisco using UDP which made TP-Link DOS "Enable UDP-FLOOD Filtering" to kick in and block the notebook's IP completely.

Relevant settings in Cisco VPN: Modify / Transport / IPSec over TCP (instead of IPSec over UDP).

Relevant settings in TP-Link: Security / Advanced Security / Enable UDP-FLOOD Filtering.

Workaround in same place: click "Blocked DoS host list" and then click "clear" if you find your IP inside.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.