Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

A subset of our users are reporting that our application refuses to run (bounces once in the dock, and then closes).

If we drill into the application bundle (/Application.app/Contents/MacOS) and execute the app from there (./Application), it runs fine. So the problem is with the bundle, not the binary.

Looking at the permissions for the bundle (ls -l | grep "Application.app"), we see something like the following:

drwxr-xr-x@ 3 user staff 102 Dec 2 15:10 Application.app

Looking at the extended attribute, we can see the following:

com.apple.quarantine     61

So we remove the quarantine attribute:

xattr -rd com.apple.quarantine "Application.app"

And the app still fails to run. The message reported in the console is:

12/11/13 8:28:37.756 AM com.apple.launchd.peruser.501[137]: ([0x0-0x37037].com.company.application[335]) Exited with code: 1

It seems this message is usually quarantine / Gatekeeper related. What other cause could there be? What have I overlooked?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Our app was crashing very early in it's launch cycle, which caused this problem.

share|improve this answer
3  
This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post. –  Carl B Dec 12 '13 at 18:39
    
This is the answer to the question; the issue was not quarantine related. The app was simply crashing very early in it's launch cycle and this is how it manifested. –  TheNextman Dec 13 '13 at 14:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.