Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am connecting to work from my Mac via Citrix Viewer 11.8.2 (255309).

To access my development VM with Visual Studio 2012, I need to use remote desktop from the Citrix machine.

I can type curly braces fine in the Citrix machine using "shift + left alt + 8 and 9", and square brackets using "left alt + 8 and 9".

If I type the '@' key whilst I logged on via RDP, '2' is returned. In the Citrix machine '@' is returned as expected.

I have a Norwegian keyboard layout.

Does anybody know how I can fix my keyboard layout?

Thanks,

Francis

share|improve this question

2 Answers 2

up vote 0 down vote accepted

I figured out how to get it to work.

If you have the RDP-session windowed instead of fullscreen, the keys work the same as in the Citrix session, and in OSX:

shift+alt+8 or 9 --> {} alt+8 or 9 --> [] alt+7 --> |

I edited the rdp file so that the resolution is as close to fullscreen as possible:

desktopwidth:i:1920 desktopheight:i:1150

share|improve this answer

In the Citrix Viewer top menu select preferences and under the tab keyboard, mark Send special key unchanged.... This fixed my problem of not being able to write curly brackets, also in full-screen.

I have just found this option, so I can't tell about any potential problems doing this.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.