Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to dual-boot CentOS 6.5 on my desktop that is currently running Windows 8.1. I have two storage devices: an SSD that has my Windows installation, and an HDD that has all of my data. Both are formatted using GPT, and Windows boots using UEFI.

I used the CentOS 6.5 live DVD (CentOS-6.5-x86_64-LiveDVD.iso) to create an EFI-bootable flash drive (it does boot properly in EFI mode). I receive an error, however, when CentOS is booting (error is below). I have a 6.4 boot DVD which boots as expected, but it does not boot in UEFI mode and therefore doesn't play nicely with my Windows installation (I have no way to access it, even using rEFInd or any other similar tools). What do I need to do to get the device to boot properly in UEFI mode?

Kernel panic - not syncing: Attempted to kill init!
Pid: 1, comm: init Not tainted 2.6.32-431.el6.x86_64 #1
Call Trace:
 [<ffffffff815271fa>] ? panic+0xa7/0x16f
 [<ffffffff81077622>] ? do_exit+0x862/0x870
 [<ffffffff8118a865>] ? fput+0x25/0x30
 [<ffffffff81077688>] ? do_group_exit+0x58/0xd0
 [<ffffffff81077717>] ? sys_exit_group+0x17/0x20
 [<ffffffff8100b072>] ? system_call_fastpath+0x16/0x1b
drm_kms_helper: panic occurred, switching back to text console
share|improve this question
1  
Is it Asus mainboard ? –  Paweł Granat Jun 23 at 13:51

4 Answers 4

The article Problem with installing Centos 6.3 on USB Stick might pertain to your problem :

If you ever face a "kernel panic" issue when trying to boot Centos 6 from your USB stick, this is due to the EFI bootloader not pointing to the root of your USB stick.

To fix this, go under the EFI folder in your USB stick, then find those files ending with *.conf and use a text editor to change the root= to your USB device. In my case, it is some things like live:UUID=UUID_OF_Partition or live:label=Label_OF_Partition

Another note to take care is instead of installing using UNetBootIn or ISO2USB, we can actually use Fedora Live USB Creator. The good thing about using it is that you can find your USB device's UUID under syslinux\syslinux.cfg.

See also this link suggesting adding rootdelay=90 reboot=a,w in grub.cfg.

Check also for BIOS update from the manufacturer of your computer.

share|improve this answer
    
Thank you! That is not a link I had found previously. I tried all of the methods given, however (including giving a new UUID to the device through GParted just to be safe), but I still receive the same error. –  Vaindil Dec 23 '13 at 1:45
    
Have you also seen this link regarding adding rootdelay=90 reboot=a,w in grub.cfg. Check also for BIOS update from the manufacturer of your computer. –  harrymc Dec 23 '13 at 9:44

They have made this version a hybrid OS so try running dd command from terminal and mount the image to USB Drive. I have done the same and it got installed properly or for a change of pace try downloading the .iso from http://mirror.kernel.org.

share|improve this answer
    
dd is the preferred method now for 6.5 according to the CentOS documentation, but it unfortunately does not allow the flash drive to boot via UEFI. –  Vaindil Dec 22 '13 at 4:45

I've had have the same issue last week. I switched back to legacy mode and then installed Linux. I used "Guided partition" and it supports dual boot automatically. If I manually create partition, it cannot even boot. (strange) The Linux I used is Ubuntu. I believe CentOS has something similar. If you are not insist in CentOS. You can try Ubuntu 13. It can support UEFI.

share|improve this answer
    
This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post. –  Kevin Panko Dec 24 '13 at 5:26
    
My BIOS does support legacy mode, but I cannot get any bootloader to find both Windows and the "legacy" installation of CentOS. My computer may also have issues with the fact that all of my drives are formatted using GPT. (The CentOS installation actually comments that there may be problems with that setup on some systems.) –  Vaindil Dec 24 '13 at 6:49
    
I have the same issue last week. I switch back to lagacy mode and then install Linux. I used "Guided partition" and it support dual boot automatically. If I manually create partition, it cannot even boot. (strange) The Linux I used is Ubuntu. I believe CentOS has something similar. If you are not insist in CentOS. You can try Ubuntu 13. It can support UEFI. –  Mickey Dec 24 '13 at 7:25
    
@Mickey Your original answer was a comment. If you want to ask for clarification, please use comments. Answers are only for answers. I have edited your answer to be real answer by replacing it with your last comment, it looks useful to me. –  gronostaj Dec 24 '13 at 11:44
    
@gronostaj Thank you –  Mickey Dec 27 '13 at 2:14

I don't think centos doesn't support gpt schemes, I think instead that the programs (for now all I think) "iso2usb" who are not able to properly load the iso images of almost all systems (I had problems with ubuntu too) in the usb stick.

My suggestion is:

  1. partitions the temporary usb stick with a mbr scheme
  2. make sure in your machine (bios) is disabled secure boot enabled and instead is enable also legacy / csm boot and when you restart pc (and break with esc or F2) choice voice without "UEFI:" prefix
  3. Run the installation from usb mbr partitioned on a hd or ssd partitioned according to the scheme gpt (i think centos supports gpt if the bios supports it) in this way it can live with windows together.

I think it's all

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.