Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After switching back to Firefox I noticed that a few sites I frequently visit don't look that good, the fonts are jagged and sometimes it makes it harder to read the text. I don't have this problem when visiting the site using Chromium. This is a screenshot of how looks, not pretty: in FF and Chromium

Why is that, and more importantly how do I fix Firefox to be pretty too?

share|improve this question
It is strange. On Chrome 30.0.1599.69, it does not use the font specified by the developers. font-family: "Open Sans","Helvetica Neue","Helvetica",Arial,Verdana,sans-serif; However, on Firefox 22.0, it used "Open Sans" to display the text. If you removed that CSS statement by using "Inspect Element", you can see the effect. –  Ivan Chau Dec 12 '13 at 9:36
Chrome blocked access to font Open Sans. –  Ivan Chau Dec 12 '13 at 9:43
That's a bit strange indeed. So it seems the font choice of the site developers is to blame. Well, not much to do about that part then. I wonder if that also causes the Outlook Webinterface pages to look similarly ugly in the font department. –  Magnus Dec 12 '13 at 18:17
possible duplicate of Ugly fonts on several Google sites in Firefox and Chrome –  fixer1234 Aug 13 at 5:51

3 Answers 3

I used to have the same problem with Google fonts (specially Google Spreadsheets) using Firefox. What it worked for me was the next:

  1. Open in Firefox the document or URL that is displaying "ugly fonts". Make sure to open a Firefox window on each monitor/screen that you have available. In my case I have the display of my laptop and 2 external monitors.
  2. Open the link Refresh Firefox
  3. Click on the button "Refresh Firefox".
  4. In the popup window, confirm clicking the button "Refresh Firefox".
  5. Your Firefox configuration and addons will be reset to default, don't worry techie guys: All your bookmarks and passwords will be saved.
  6. Wait until Firefox closes itself and gets open again.
  7. Once The Firefox is refreshed you are good to go, check again the page with ugly fonts and the problem should be gone.

Other option insteas the link showed in the step #2 is go to url about:support. The button "Refresh button" is on the up right corner.

share|improve this answer

This might be the answer you're looking for. This article also suggests a couple of other solutions.

share|improve this answer
These both seem geared towards Windows users, but the parts that apply to Linux don't make any difference at all :( –  Magnus Dec 12 '13 at 18:15

It could have happen that you enabled the page zoom holding CMD or CTRL and scrollwheel. That can make even images look jaggy. Try from menu selecting View > Zoom > Reset.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.