Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have recently installed the Chrome extension "PasswordBox", however I am not able to disable it in incognito.

As you can see on the image below the checkbox "Allow in incognito" is grayed out for PasswordBox, while it can be toggled for "PageSpeed Insigts":

enter image description here

Clicking the checkbox does nothing at all.

I have tried contacting PasswordBox, however they failed to come up with a solution that wouldn't also disable PasswordBox in a normal browser window.

I am using OS X and installing it on the Windows version of Chrome seems to work.

Is there a way of disabling "PasswordBox" in incognito mode but have it enabled in normal mode, perhaps by editing ~/Library/Application\ Support/Google/Chrome/Default/Preferences?

share|improve this question
    
Just as a pure test with no expectation of it working, try right-clicking the Allow in incognito check-box and select Inspect element. Now look in the DOM inspector for the tag (you can click the magnifying-glass at the bottom then click the check-box again to force Chrome to highlight it in the DOM inspector if necessary). The tag should look like this: <span i18n-content="extensionSettingsEnableIncognito" disabled="">Allow in incognito</span> Double-click on the part that says disabled and press the Delete key then Enter. It should now be enabled. Click it and see what happens. –  Synetech Dec 17 '13 at 2:25
    
@Synetech This doesn't work as after opening a new incognito window (and seeing that it didn't disable the extension), the checkbox was back to being both checked and disabled. –  Tyilo Dec 17 '13 at 9:23
    
That’s what I figured. :-( Try manually changing the setting: (1) Completely close Chrome. (2) Open your user-data directory. (3) Open the file Preferences in a text-editor like Notepad. (4) Locate the section related to the extension (in this case do a search for dljbcjbfojhlfhgenhepllagfecdpchb. (5) In it’s block (delimited by a pair of matching, indentation-aligned braces: "dljbcjbfojhlfhgenhepllagfecdpchb": {…}), find the line "incognito": true, (6) Change true to false, save, and test. –  Synetech Dec 17 '13 at 14:46
    
@Synetech The weird thing is that there is no "incognito": true. I have already tried to add "incognito": false, which didn't work. –  Tyilo Dec 17 '13 at 15:14

1 Answer 1

I found with our extension that it was associated with the permissions that you ask for in the manifest.json file. We use the "proxy" permission

"permissions": [
  "proxy"
],

I can't find any documentation about it on the extensions page.

Maybe try toggling your permissions one at a time to figure out which one is causing it?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.