Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Here is the thing! am on day 5 of no wired internet connection. I have spent the last 4 days searching through every forum and Q&A sites, until i finally decided to post this, so I have done my homework. Before I take my laptop to maintenance shop for hardware failures i want to check with you guys first.

Problem Description: Like the question says my wired connection stopped working suddenly after an update. I am using ubuntu 12.04 LTS. Network Manager says Wired Networks disconnected. Wireless is working perfectly. And also it doesn't work on Windows 7 too, it says cable unplugged. I have tried the cable on other computer and it works perfectly.

nm-tool output:

NetworkManager Tool

State: connected (global)

- Device: wlan0  [Connectify-me] -----------------------------------------------
  Type:              802.11 WiFi
  Driver:            iwlwifi
  State:             connected
  Default:           yes
  HW Address:        9C:4E:36:29:F7:D4

  Capabilities:
    Speed:           58 Mb/s

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points (* = current AP)
    TP-LINK_8AB114:  Infra, A0:F3:C1:8A:B1:14, Freq 2452 MHz, Rate 54 Mb/s, Strength 25 WPA2
    ZTE_HG_0:        Infra, 00:1D:0F:BF:BE:61, Freq 2437 MHz, Rate 54 Mb/s, Strength 47
    ZTE_HG_0:        Infra, 00:21:27:C1:19:D9, Freq 2437 MHz, Rate 54 Mb/s, Strength 39
    *Connectify-me:  Infra, E8:39:DF:3E:AF:8E, Freq 2462 MHz, Rate 54 Mb/s, Strength 87 WPA2

  IPv4 Settings:
    Address:         192.168.241.104
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.241.1

    DNS:             192.168.241.1


- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            atl1c
  State:             unavailable
  Default:           no
  HW Address:        00:1E:DE:F7:A6:C9

  Capabilities:
    Carrier Detect:  yes

  Wired Properties
    Carrier:         off

sudo lshw -C network output:

  *-network               
       description: Ethernet interface
       product: AR8152 v2.0 Fast Ethernet
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: eth0
       version: c1
       serial: 00:1e:de:f7:a6:c9
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=atl1c driverversion=1.0.1.0-NAPI latency=0 link=no multicast=yes port=twisted pair
       resources: irq:48 memory:f7e00000-f7e3ffff ioport:e000(size=128)
  *-network
       description: Wireless interface
       product: Centrino Wireless-N 2200
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: c4
       serial: 9c:4e:36:29:f7:d4
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=3.2.0-57-generic firmware=18.168.6.1 ip=192.168.241.104 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
resources: irq:46 memory:f7d00000-f7d01fff

ifconfig eth0 output:

eth0      Link encap:Ethernet  HWaddr 00:1e:de:f7:a6:c9  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:48 

So there you have it guys! Let me know if you need additional information. So Please help me!!!

share|improve this question
    
It is probably a driver problem. Can you please post the output of lspci -vnn | grep -i net –  MariusMatutiae Dec 14 '13 at 8:24
    
01:00.0 Ethernet controller [0200]: Qualcomm Atheros AR8152 v2.0 Fast Ethernet [1969:2062] (rev c1) 02:00.0 Network controller [0280]: Intel Corporation Centrino Wireless-N 2200 [8086:0890] (rev c4) –  user2057125 Dec 14 '13 at 8:58
    
@MariusMatutiae..i have also downloaded compat wireless and loaded the module atl1c, but still no luck. –  user2057125 Dec 14 '13 at 9:03
    
Try mii-tool -r, pls –  MariusMatutiae Dec 14 '13 at 11:54
    
when i tried that without sudo i get SIOCGMIIPHY on 'eth0' failed: Operation not permitted SIOCGMIIPHY on 'eth1' failed: Operation not permitted SIOCGMIIPHY on 'eth2' failed: Operation not permitted SIOCGMIIPHY on 'eth3' failed: Operation not permitted SIOCGMIIPHY on 'eth4' failed: Operation not permitted SIOCGMIIPHY on 'eth5' failed: Operation not permitted SIOCGMIIPHY on 'eth6' failed: Operation not permitted SIOCGMIIPHY on 'eth7' failed: Operation not permitted no MII interfaces found When i use sudo i get restarting autonegotiation... –  user2057125 Dec 14 '13 at 15:24
show 8 more comments

2 Answers

Yours is not a clear-cut situation, so we go by successive approximations.

First, issue these commands:

    sudo service network-manager stop
    sudo ifconfig eth0 down
    sudo ifconfig eth0 up
    sudo dhclient eth0

and see whether this works. In any case, re-issue

    sudo service network-manager start

Second. We may try to install the latest atl1c driver. Go to a convenient, empty directory, and issue these commands:

    sudo apt-get install linux-headers-generic build-essential
    wget http://wireless.kernel.org/download/compat-wireless-2.6/compat-wireless.tar.bz2
    tar xvf compat-wireless.tar.bz2
    cd compat-wireless-2012-12-18/
    scripts/driver-select atl1c
    make
    sudo make install
    sudo rmmod atl1c 
    sudo modprobe atl1c
    sudo ifconfig eth0 down
    sudo ifconfig eth0 up
    sudo dhclient eth0

and see now whether this works. Just let me know, if at all solvable your problem will require a few iterations.

share|improve this answer
    
All of the above didn't solve the problem. sudo ifconfig eth0 up and sudo ifconfig eth0 down didn't give any response` but sudo dhclient eth0 stays on the prompt without any response, it doesn't close. The output of sudo make install this might be helpful make[1]: Entering directory `/usr/src/linux-headers-3.8.0-34-generic' INSTALL /home/take/trouble/compat-wireless-2012-12-18/compat/compat.ko Can't read private key INSTALL /home/take/trouble/compat-wireless-2012-12-18/drivers/net/ethernet/atheros/atl1c‌​/atl1c.ko Can't read private key DEPMOD 3.8.0-34-generic –  user2057125 Dec 14 '13 at 10:45
    
Can't read private key does not mean anything, just plunge ahead. But did you stop network manager before trying the first method? It is important. –  MariusMatutiae Dec 14 '13 at 11:24
    
yes i did. It stopped my wifi connection too. I re enabled it to post here. –  user2057125 Dec 14 '13 at 11:30
add comment

Wired properties carrier is off; must activate it:

echo on | sudo tee /sys/class/net/eth0/device/power/control
share|improve this answer
    
Could you explain your answer little bit more? –  Nikolay Feb 28 at 14:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.