Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I had Ubuntu 9.04 working with nvidia display drivers, then I upgraded Ubuntu to 9.10. It boots to the desktop, the desktop looks great for a moment and then I get a screenful of pink and blue noise. How can I fix this? I've read that I should be able to drop out of the GUI with Ctrl-Alt-F1, but that doesn't work.

share|improve this question
    
are you running 64 bit or 32 bit? –  GiH Nov 11 '09 at 5:27
    
running 32 bit. –  Jim Sweeney Nov 11 '09 at 5:51

4 Answers 4

up vote 1 down vote accepted

I got the help of a friend and here's what he ended up doing: Booted into recovery shell. Edited /etc/X11/xorg.conf and changed "nvidia" to "vesa". This allowed us to run the desktop GUI without getting the problem. He then went to the list of available display drivers under the "hardware drivers" menu and we selected a previous version of the nvidia proprietary drivers (just previous to the latest). The package manager downloaded and installed these drivers. We then changed "vesa" back to "nvidia" in xorg.conf, rebooted, and everything was good. The reason I couldn't drop out to a shell from the start was that the video problem seemed to kill the keyboard too. We also tried connecting an external monitor per DigitalRoss, but we never got anything to display. So the bottom line is that I'm not on the latest nvidia drivers, but at least I didn't have to downgrade anything else.

share|improve this answer
    
I am having this same issue. What version of the nvidia driver did you end up using? –  Justin Feb 3 '10 at 18:51
    
NVIDIA accelerated graphics driver (version 173) –  Jim Sweeney Feb 13 '10 at 15:46

Go to System > Administration > Hardware drivers

Then activate the recommended drivers. If you've already done that, it most likely is a bug. There have been a lot of reported bugs in 9.10

share|improve this answer
    
I just have noise on the screen and can barely see the mouse move, so I can't use the menu –  Jim Sweeney Nov 11 '09 at 5:33
    
sounds like bugs to me, id downgrade to 9.04 until they've figured everything out with 9.10... I don't see how you're supposed to activate the drivers without being able to see anything. Try rebooting and see if you have enough time before your screen messes up to activate the drivers. –  GiH Nov 11 '09 at 5:40
    
There is very little time before the screen turns to noise. I can boot in recovery mode to a root shell. Can I downgrade from there? –  Jim Sweeney Nov 11 '09 at 5:54
    
honestly i think its better for you to post this in the ubuntu forums, easier for the back and forth. Here is a downgrade howto help.ubuntu.com/community/DowngradeHowto –  GiH Nov 11 '09 at 23:24
    
if you are posting on another forum, please let us know when you find a solution in case someone else has the same problem –  GiH Nov 12 '09 at 17:13

If there is a Fn key on your keyboard, you might want to try Ctrl-Alt-Fn-F1 to get to the text console. The F1 to F6 keys will get you to separate text consoles, and Ctrl-Alt-Fn-F7 will get you back to the GUI.

Check this thread on UbuntuForums if you want to mess with the NVidia VGA driver.

share|improve this answer
    
Ctrl-Alt-Fn-F1 doesn't seem to do anything but Ctrl-Alt-Fn-F2 seems to turn my fan off :-) –  Jim Sweeney Nov 11 '09 at 6:28

The problem you are having is not precisely with Ubuntu, except in the sense that they take some responsibility for setting up Xorg and for including drivers for the text-based consoles.

What you really need to do is find an /etc/X11/xorg.conf that works. On a cast-off Inspiron 8000, notorious for not running Linux (unless you have never-"up"graded firmware) I managed to get Ubuntu 9.04 working after some pain. I ultimately found out that the issue was that the Dell firmware was providing bogus data on frequency ranges and so xorg was rejecting all the workable modelines.

I was able to make the system usable for debugging by plugging in an external LCD to the VGA port. Another way would be to boot up into text console mode rather than X, which I believe can be done by having GRUB boot into "recovery mode". (I didn't have to try that due to the external monitor.)

Fixing your Xorg Xserver is going to be painful and it deserves a separate SO question so I don't have to answer it. At least if you can get going in console mode you have a chance. The kernel's console driver is considerably less ambitious and less prone to failure than the Xserver driver.

(And I should add a note: it looks like I have blamed Xorg, but really the problem is the secrecy surrounding the video chips. Because they are afraid of patent wars, they publish no interface info. It's really a pity they don't make an exception for the tiny part of the chip that does the 2D stuff, and it's unfortunate that the patent court and other influences have made the USA such a legal minefield.)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.