Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have 2 computers: echo.local is running Ubuntu 9.04. justin.local is running Mac OS 10.6.1. X11 version on the mac is 2.3.4.

I open X11 on the mac, and open a new xterm window (Applications Menu -> Terminal), everything is fine. Keyboard works as expected.

I do ssh -X echo.local from the mac (connecting to the linux box), and from the linux command prompt, start xterm - everything is fine. Keyboard works as expected.

I do gnome-session from the linux command prompt (through SSH), gnome launches, but keyboard mapping is ALL types of screwed up. If I kill gnome-session and open an xterm via ssh, keyboard mapping is still screwed up. If I then kill the SSH session entirely, and do X11 -> Applications Menu -> Terminal, opening a brand new xterm window on the mac with no SSH session running at all ... keyboard mapping is still screwed up.

Only after I quit X11 and relaunch, is the keyboard mapping back to normal.

Keyboard layout under GNOME is Apple->MacBook/MacBook Pro.

share|improve this question
    
Justin - that answer worked for me, can you perhaps mark it as the correct answer? – Danny Staple Nov 6 '11 at 23:01
up vote 2 down vote accepted

Try creating a xmodmap first:

sudo xmodmap -pke > .xmodmaprc

After that, ssh -X gconf-editor

Navigate to:

Desktop > Gnome > Peripherals > Keyboard

Select "layout" and then add "us".

Restart X11

... This is half me fooling around, and the other half blatantly stolen from https://bugs.launchpad.net/ubuntu/feisty/+source/vino/+bug/112955/comments/31

I'm not sure if the .xmodmaprc needs to be created, but hey.. the above steps worked for me!

Andrew

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .