Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I live in a dormitory where the Internet connection is through a proxy via Ethernet ports on the LAN.

After I install VirtualBox and install Kali Linux, my connection is automatically blocked by the server. When I asked the IT guy why that is, he told me that when the server detects two systems using the same port, it automatically blocks that port.

I hate this proxy because I cannot use the FileZilla extension. I have to pay for a VPN to use this programs and I don't like it.

How can I get this to work?

share|improve this question
    
Just turn off the networking in Virtualbox, or disable the Virtual Ethernet adapter that is created by Virtualbox in your Network and Sharing options. –  Michael Frank Dec 16 '13 at 2:17
    
Thank you for advice but same time i need to use internet for bouth os system. i need it. –  Jack Sparrow Dec 16 '13 at 13:24
    
You should add that information to your original question then. –  Michael Frank Dec 17 '13 at 2:03

1 Answer 1

It is very simple: before starting the VM, go to Network -> Adapter 1 -> Attached to, and you choose NAT. This means that your host will act as if it were a router, i.e., it will MASQUERADE the fact that there are several pcs behind it. And you are now done. In line of principle, you can do this for as many pcs as you like.

Keep in mind just one thing: if you enable NAT, you will be unable to communicate between host and guest. To do that, enable a second adapter, choosing either host-only or Internal Network. The different between the two is that, if you have multiple VMs, with the first each VM can only talk to the host but not to the other guests, while in the second case all machines, virtual or not, will be able to talk to each other.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.