Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have installed GNS3, I use the following image: c2691 IOS.image

So when I try to start the device 1st time, i get this error in the console:

=> ---------Traceback lines (saved in exception.log)----------
Traceback (most recent call last):

  File "GNS3\Scene.pyo", line 725, in slotStartNode

  File "GNS3\Node\IOSRouter.pyo", line 607, in startNode

  File "GNS3\Dynagen\dynagen.pyo", line 2542, in check_ghost_file

  File "GNS3\Dynagen\dynagen.pyo", line 2571, in _create_ghost_instance

  File "GNS3\Dynagen\dynamips_lib.pyo", line 3090, in __setghost_file

  File "GNS3\Dynagen\dynamips_lib.pyo", line 4998, in send

DynamipsError: 203-Bad number of parameters (3 with min/max=2/2)

On the subsequent attempts to start the same device, I get this error:

-----------------------------------------------------------
---------Traceback lines (saved in exception.log)----------
Traceback (most recent call last):

  File "GNS3\Scene.pyo", line 725, in slotStartNode

  File "GNS3\Node\IOSRouter.pyo", line 607, in startNode

  File "GNS3\Dynagen\dynagen.pyo", line 2542, in check_ghost_file

  File "GNS3\Dynagen\dynagen.pyo", line 2565, in _create_ghost_instance

  File "GNS3\Dynagen\dynamips_lib.pyo", line 2163, in __init__

  File "GNS3\Dynagen\dynamips_lib.pyo", line 4998, in send

DynamipsError: 206-unable to create VM instance 'ghost-c2691 IOS.image-127.0.0.1.ghost'

-----------------------------------------------------------

So any ideas how to resolve this?

EDIT:

Same happens on windows 7 and Ubuntu 13.04.

share|improve this question

migrated from networkengineering.stackexchange.com Dec 16 '13 at 11:43

This question came from our site for network engineers.

DynamipsError: 206-unable to create VM instance 'ghost-c2691 IOS.image-127.0.0.1.ghost'

DynamipsError: 203-Bad number of parameters (3 with min/max=2/2)

This seems to be addressed in the GNS3 FAQ. If it is the same issue, ensure that your server‘s hostname and path to the image are correct.

share|improve this answer
    
Also see:commonerrors.blogspot.com/2013/10/… – Mike Pennington Dec 15 '13 at 12:55
    
The first sugegstion I cannot do, as I can't even boot a device. And I tried second one, but it did not solve the problem – galdikas Dec 15 '13 at 13:04
    
there shouldn't be a need to boot a device. Make your corrections in the gns3 config file – Mike Pennington Dec 15 '13 at 14:30
    
As it turns out my lecturer gave me a faulty image file. I now was provided a proper one, and everything works :) Thanks for your help! – galdikas Dec 15 '13 at 23:07
1  
ok please add another answer to your question with this information – Mike Pennington Dec 15 '13 at 23:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .