Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I can't get USB tethering to work. My setup:

  • iMac with Mac OS 10.6.2
  • iPhone 3G, Sofware version 3.1.2 (Build 7D11)
  • The phone shows up in iTunes and syncing works as it should.

I went to System Preferences / Network and added the iPhone as a Network Service. To the right there is a status message for the selected service.

With the iPhone not plugged in, the status message reads:

Either the cable for iPhone is not plugged in or the device is not responding.

With the iPhone plugged in, the status message reads:

Either the cable for iPhone USB is not plugged in or the device is not responding.

Almost identical messages, the only difference is "USB".

Any clues?

share|improve this question

4 Answers 4

up vote 6 down vote accepted

It seems the Network prefs window is one of few settings windows where you have to Apply your changes before they take effect. I clicked on Apply and now it works.

share|improve this answer
    
I'd set this as your accepted answer then, so people know when looking through the web page –  admintech Nov 11 '09 at 12:37
    
I will, as soon as superuser allows me to (two more days). –  Arne Evertsson Nov 11 '09 at 21:02

The 64 bit kernel apparently works since 10.6.3.

Also, I found this thread on Apple's support forums says to try and USB tether with iTunes running.

I had my old iPhone working fine via usb, but it stopped when i got a warranty replacement. You have to remove all the old iphone devices if they're in your System preferences, turn on iTunes, and then plug in the phone to find tethering.

Up until I tried to start USB tethering without running iTunes (i don't automatically sync with itunes when I plug in the iphone), I just got a message that said the device hadn't been setup, and when I'd go to setup the device, it would say the device isn't connected.

Hope that helps!

share|improve this answer
    
Yes, I've heard that sometimes tethering does not work until iTunes is opened. –  Simon Sep 23 '10 at 3:46

None of these answers fixed my problem, but this worked for me:

  • Copy /System/Library/Extensions/AppleUSBEthernetHost.kext to a backup folder (Desktop) and delete the original
  • Re-download the latest version of iTunes (http://www.apple.com/itunes/download/)
  • Install iTunes, this will update your "AppleUSBEthernetHost.kext" file.
  • Disconnect USB-connection to iPhone
  • Re-connect iPhone via USB
share|improve this answer

Are you running 10.6.2 with the 64 bit kernel? The USB tethering driver doesn't work in that mode, only 32 bit: http://discussions.apple.com/thread.jspa?threadID=2138547&tstart=195

share|improve this answer
    
No I'm not running the 64 bit kernel. My problem was only that I didn't click on the Apply button. –  Arne Evertsson Feb 9 '10 at 9:39

protected by Diago Dec 22 '10 at 19:53

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.