Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to print on network printer Xerox WorkCentre 5755 from Solaris with CUPS 1.4.5 installed. Due to lack of any Solaris related information I have set the printer up with manufacturer provided Windows Generic PPD. Now every attempt to print is rewarded with page containing exactly

ERROR: undefined
OFFENDING COMMAND: ENTER
STACK:

This is the only snippet I found in above mentioned xrwc5755.ppd, regarding ENTER command:


*JCLToPSInterpreter:"@PJL COMMENT XRXend<0A>@PJL ENTER LANGUAGE = POSTSCRIPT<0A>"
*JCLEnd:"<1B>%-12345X@PJL EOJ<0A><1B>%-12345X<0A>"

I have no idea whether there is anything wrong about it at all. Could this issue be somehow connected to fact, that this PPD file was designated for Windows?

share|improve this question
    
You might try it as a generic PostScript printer. Looking at how "serious" the device is, it's 100% it supports PostScript. –  Laszlo Valko Dec 17 '13 at 23:50
    
PPD files are not OS-specific; a Windows file will work fine under any other OS. As @Laszlo suggested, start with the generic PS driver. That should work, but will not give you access to specific printer features like trays, paper sizes, etc. –  hdhondt Dec 22 '13 at 22:41
    
@hdhondt Thank you for your comments. I have tried generic PS with the same result. I guess there has to be something wrong with CUPS itself and this particular installation. –  Mr. Tao Dec 23 '13 at 0:44
    
The error you are getting is PS's action on receipt of an invalid command (in this case the word ENTER). The PJL sequence you posted is sent to the printer to switch it into PS. If the problem was there, the error should be at @PJL as that is not a PS command either. The ENTER must be at the very beginning of the printer output stream for it to cause that error. Try printing to file, and then examine the file with a text editor to see what's at the front of it. –  hdhondt Dec 24 '13 at 9:27
    
@hdhondt I printed to file using Acrobat Reader as I could not manage to do it from any other program. Interestingly enough, file produced contains no ENTER, yet it fails with the same error. –  Mr. Tao Jan 6 '14 at 18:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.