Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I run a local IIS server to develop a website and it works. If I try to debug however it stated "Unable to start debugging on the web server. You do not have permissions to debug the web server process." as explained on this site. It also has the solution on there, run as administrator.

The problem is that I also have to publish the website to a remote computer. I've create a networkmap to the correct folder (drive W). Publishing to this drive only works if I dont run VS as administrator. As admin it gives the error The path 'W:\' does not exist or you do not have access

Now I'd like to do both without having to restart VS everytime in a different mode.

Now I tried the other option in the first error message, which is to run IIS as the same user. I changed the application pool user and now when I look at the taskmanager both devenv.exe and w3wp.exe run as h.delsing, but it still doesnt work without explicitly giving administrator priviledges. Do I need to change something else to run both IIS and VS as the same user?

Another option would be to allow access to W as admin. Strange thing is that if I run another program as admin (totalcommander) I still have access to the W drive. So i have no clue on how to do this.

The same setup worked fine on Windows 7 which uses the same authentication structure as far as I know. Only difference is that Windows 8 is linked to my live account. I sure hope that is not what causing the problem, as I read that Windows is a little sketchy when it comes to what account it is actualy using.

So in short:

  • How can I run IIS and VS as the same user without admin for debugging?
  • Or how can I allow access to the W drive as admin from VS?
share|improve this question
    
I willing to almost guarantee the reason your having this problem is because your account is linked to your Microsoft Account. This on a domain? –  Ramhound Dec 18 '13 at 12:20
    
The reason the W drive didnt work, is that it wasnt connected yet. I had to run the explorer once as administrator and access the W drive. Then the connection was made and it works in VS. –  Hugo Delsing Apr 7 at 6:59

2 Answers 2

Do you really need to use the full version of IIS for your project?

I think you could try IIS Express instead of the full IIS, this runs locally on your developer machine and allows debugging without running Visual Studio in admin mode, this might be a way to both get access to the network publishing and local debugging.

Have a look at Using IIS Express to do configure your web Project to run under IISExpress when debugging.

share|improve this answer

You can run Process Monitor to see what user account is being used to access the W:\ drive.

share|improve this answer
    
This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post. –  Kevin Panko Apr 6 at 14:44
    
If it's a permissions issue then knowing which user is trying to access the W:\ can help resolve the problem. –  Todd Smith Apr 7 at 13:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.