Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I can't source any changes to my .zshrc (or my .bash_profile for that matter), because I get this error when I try:

/Users/ME/.zshrc:source:100: too many open files: /Users/ME/.zshrc

I've tried ulimit -n 10000, but it doesn't work. I've also tried adding a launchd.conf file (there wasn't one there, I had to create it) to permanently change the hard & soft file limit, but on reboot, my terminal instantly crashes with a Process Completed message. (deleting the launchd.conf file & rebooting fixes this issue).

This could be related: for some reason, my $PATH variable is extremely long, as in thousands of characters. There are many repeating parts, for example, here is part of what I get if I do an echo $PATH :

/Applications/MAMP/bin/php/php5.4.10/bin:/Applications/MAMP/bin/php/php5.4.10/bin:/Applications/MAMP/bin/php/php5.4.10/bin:/Applications/MAMP/bin/php/php5.4.10/bin:/Applications/MAMP/bin/php/php5.4.10/bin........

That continues hundreds of times.

This made me think something in MAMP is rewriting my $PATH variable over and over which is causing all my other problems, but I can't find where its happening, and I don't know how to fix it.

Has anyone run into this before??

share|improve this question
    
also, check your ~/.zshrc and, if you're using oh-my-zsh, anything in your .oh-my-zsh directory structure. –  Donovan Dec 18 '13 at 18:18

1 Answer 1

To find what's broken in your "path" variable, on Maverics, you can need to check those files:

cat /etc/paths

ls -l /etc/paths.d/ (I bet that you will find something about MAMP!)

I would move everything out from /etc/paths.d/ to somewhere safe, reboot, and see if that helps. If it does (as you can have paths in other places as well) - post files from /etc/paths.d/ related "MAMP" and we will have a look.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.