Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have wanted to install Linux (specifically Linux mint x64 maya) on an older Seagate HDD (Model: ST3160812AS, Serial: 5LSDP211, Firmware: 3.AAE) I had acquired.

With various Linux distributions installations (Mint, LMDE and Ubuntu 12.04) I get the error directly at boot: Loading operating system... Read error

I have tried multiple partition settings using the installers and Gparted but each produces the same error.

I carried out a CHKDSK on windows with no errors received. I also carried out a test on linux using the disk manager on Mint.

No test yet has show me any problem with the drive except when I booted in Daraks boot and nuke. It suggested the disk may have dead sectors and denied to load Daraks boot and nuke any further.

I was surprised when a single install of Windows 7 can successfully boot without problems.

I hope someone can point me in the right direction as to why Linux wont boot but windows will?

Is there a way to fix such an issue?

Please note:

I currently have 5 other HDD's with other Operating systems installed. All work well and do not have any problems.

I have also ran a memory test on my ram using memtest86+ (no errors were found)

share|improve this question
    
Any chance you could/have run bootinfoscript? –  winterswift Dec 19 '13 at 7:06
    
Probably the linux driver try to use the hard disk in a mode, which it doesn't support. Try to set smaller sata protocol settings in your bios. If it works, you could set them back to "auto", but you need to say linux with a kernel parameter, exactly which method it should use. –  peterh Dec 19 '13 at 10:07

1 Answer 1

Very weird! I ended up fixing it by changing the bios settings as Peter suggested.

To do this I changed my HDD mode to: IDE, once this was done I rebooted and installed Linux mint as usual to a single HDD.

After the installation was complete I was able to boot into Linux using both IDE mode and then ACHI mode aswell.

share|improve this answer
    
If anyone has any idea why this was happening it would good to know? Cheers –  user283076 Dec 19 '13 at 21:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.