Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have installed Ubuntu 9.10 on an old PC and it is mostly working, except for some heavy drawing defects that show up whenever I start dragging a window or scrolling inside a window or menu. It looks like the video driver copies the rectangle being moved to the wrong location.

I have taken a look in /var/log/Xorg.0.log and the following line shows the detected video card:

(--) PCI:*(0:0:8:0) 102b:0519:0000:0000 Matrox Graphics, Inc. MGA 2064W [Millennium] rev 1, Mem@ 0xf9800000/16384, 0xfb000000/8388608, BIOS @0x????????/65536
(==) Using default built-in configuration (30 lines) (==) ---
Start of built-in configuration ---
Section "Device"
Identifier "Builtin Default mga Device 0"
Driver "mga"
EndSection

How do I fix the drawing defects?


It turned out that the 24 bit color depth (automatically selected by ubuntu 9.10) was the problem; apparantly the mga driver doesn't handle this well for cards with little memory. I took the following steps to resolve the issue (you can skip the first three steps if you already have a semi-working xorg.conf file):

  1. Reboot ubuntu in recovery mode, to get a root console without X running.
  2. Run Xorg -configure to generate a xorg.conf.new file
  3. Copy the file to /etc/X11/xorg.conf with cp xorg.conf.new /etc/X11/xorg.conf (assuming it didn't exist yet; that's why I generated it)
  4. Open the new config file with sudo nano /etc/X11/xorg.conf and make sure the screen section is configured for 16 bit color depth like this:

    Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        DefaultDepth 16
        SubSection "Display"
            Viewport   0 0
    	Depth     16
            Modes "1024x768"
        EndSubSection
    EndSection
    

I can't guarantee those were the only important changes I made - I tried a few things in my attempts to create a valid xorg.conf file. But I'm pretty sure that the screen section was the important part.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

This thread has a solution: http://ubuntuforums.org/showthread.php?t=878780

in your xorg.conf file where it says DefaultDepth 24 change this to read DefaultDepth 16, maybe even try making it 8, but I know 16 works. The card doesn't have enough memory to run any higher than 800x600 at 24 depth, so by changing the depth you will free up enough memory to run at higher resolutions

share|improve this answer
    
I have edited the question to be just about my specific video card issue now. I already knew the xorg.conf is no longer present; I've removed mention of it to avoid further close votes for duplication. –  wcoenen Nov 11 '09 at 17:26
    
have tried to install nvidea ? –  joe Nov 11 '09 at 17:48
    
Matrox cards are not nvidia cards. But I looked anyway at the "restricted drivers manager" dialog - it doesn't have any proprietary drivers to offer for my Matrox Millenium card. –  wcoenen Nov 11 '09 at 17:54
    
i have changed my answer –  joe Nov 11 '09 at 18:16
    
It turned out that the automatic settings used color depth 24, which seemed to be the factor which caused the drawing defects. I am now happily running at 16 bit color depth, 1024x768 resolution without drawing defects –  wcoenen Nov 11 '09 at 19:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.