Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a web app that has about 20 js files that are loading. I tried using Ctrl Shift F (Search Sources) to search for function names across all of the source (js) files. But when I search for myFunction using the Search Sources feature, it doesn't find anything (No matches found.). If I open the source file that contains myFunction and use Ctrl F to search, it is found right away. Opening the file containing myFunction before using Search Sources doesn't change anything.

It makes me think that Search Sources doesn't actually do what it says or I have to configure it to search js files, which seems odd.

Chrome 30.0.1599.114 Ubuntu 12.04

share|improve this question
    
Hmm, I tried it and it worked fine. Have you changed any settings? Click the gear-icon in the bottom-right; is Search in content scripts check in the General tab? Also, are the dev-tools docked? –  Synetech Dec 20 '13 at 20:35
    
Good suggestions (Search in was not checked) but they didn't change the results. –  jcollum Dec 20 '13 at 20:47
    
Huh, it looks like checking "Search in" and closing the tab then reopening fixed it. Make an answer that says that and I'll confirm it. –  jcollum Dec 20 '13 at 20:50

1 Answer 1

up vote 1 down vote accepted

Make sure that the Search in content scripts settings is checked. It could be that you had cleared it at some point in the past and forgotten to re-set it, or perhaps an upgrade to Chrome modified the setting (I can’t find any confirmation that it currently defaults to off, but others seem to have had it un-checked without realizing it).

  1. Click the gear-icon in the developer tools to open dev-tools settings
  2. Check Search in content scripts
  3. Close the tab, re-open it, re-open the dev-tools

Screenshot of search-in-content setting in dev-tools settings

share|improve this answer
    
That's what I'm doing. –  jcollum Dec 20 '13 at 20:14
    
Oops, I saw the second hotkey. –  Synetech Dec 20 '13 at 20:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.