Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After a wine install/uninstall audio is broken and MDM fails as a boot up service, but still works via sudo. How should I trouble shoot?


Last night I installed Wine, installed then removed mono-complete (and it's dependencies) and then ran apptitude update which when finished made my system seem unstable so I rebooted.

Upon reboot, the system hangs on the LM logo. F2 shows that starting MDM failed. So I tried

apt-get uninstall MDM
apt-get intstall MDM

and rebooted, this didn't help so I tried

dpkg-reconfigure -a

Which also didn't help, however, if I open up another TTY I can use

sudo MDM 

and MDM starts fine.

It seems quite similar to these bugs:

Linux Mint fails to start X automatically after update, but X still works http://forums.linuxmint.com/viewtopic.php?f=206&t=141808

but I don't have infinality installed, nor can I detect any issues with mdm.conf


I'm not sure if this is related (and if not I'll start a new question), but upon login I noticed I no longer had sound. Clicking the sound system tray icon, I noticed that the mixer is now pointed to "Dumy Output". I tried to go to sound settings to reconfigure this, but there are no detected sound cards to choose.

Please let me know if any log files would be helpful.

Any and all help is appreciated.

share|improve this question
add comment

2 Answers 2

up vote 0 down vote accepted

Check to see if drivers are installed for your sound hardware.

Open /var/log/apt/history.log

Check what packages were removed. It sounds like you removed something that you need. I just realized this is pretty old. But in case it helps ...

share|improve this answer
    
sorry, I should have deleted this; I've re-installed with the actual Mint KDE 16 release and currently have no problems. I'll try to edit this question to be more useful / solvable. –  virtualxtc Apr 25 at 3:13
add comment

I've been up all day trying to fix an error that I think is very similar to this. I searched all the related help sources to find out why MDM was not booting except when run with sudo (as in, it fails on boot and I enter terminal using alt-F6 and I type sudo mdm), and I found the following command fixes it:

sudo update-rc.d mdm defaults

Furthermore, back when I had to run mdm using sudo, my audio wouldn't work. Now after running the above command and having a proper boot, the audio works again.

Just as a caveat, I don't really know what I'm doing so it's not like I identified the problem in all its generality. On the other hand, I don't think there's any harm in running the above command because it's setting something or other to default.

Furthermore, I got this from Pela's answer on http://forums.linuxmint.com/viewtopic.php?f=206&t=141808

I just ran the update-rc.d command for mdm that I've listed above and I didn't bother with any of the other commands regarding the installation of infinality etc.

I hope this helps, and good luck!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.