Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Firefox 2.0.0.17. I had disabled image looping (GIF animation) so that images only looped once. Now I want to turn the default looping behavior back on, so I reset image.animation_mode back to normal in the about:config window.

But this does not work; Firefox is still looping animated images only once. Is there another setting I need to set to restore the default image looping behavior?

UPDATE

My wife and kids also use the same Firefox on the same PC, and their image looping works fine. I never changed their settings from the default behavior, though. So when changing my setting and then back again, there must be something else that needs to be reset in my Firefox profile. I just don't know what it is.

share|improve this question

3 Answers 3

You'll need to probably wipe your cache? That would be my guess, since you put the setting back.

share|improve this answer
    
I've wiped the cache many times. Does not affect it. –  David R Tribble Nov 11 '09 at 20:38

With image.animation_mode back to normal, the GIF should be playing.

It might be that an external program or an add-on are blocking the play.
Check if the play is perhaps being blocked by:

  1. if an add-on such as Adblock
  2. A firewall or other security program.
share|improve this answer
    
Can't be this because image looping works fine the same Firefox browser but with a different user profile (see update in the question). –  David R Tribble Nov 11 '09 at 20:26
    
This seems to exclude point 2. Point 1 can still be valid with either (1) You've tweaked some other undocumented setting, or (2) an add-on that works per profile. But why don't you simply uninstall FF2, clear out all its directories and install FF3.5? –  harrymc Nov 11 '09 at 20:49
    
Yep, some day. –  David R Tribble Nov 12 '09 at 22:46

From here

In Mozilla Suite and Firefox:

  1. In the Location Bar type about:config and hit Enter
  2. Type "anim" in the Filter field (to quickly find the needed preference)
  3. Double-click the image.animation_mode line and edit it to one of the following:

    none — will prevent image animation 
    once — will let the image animate once 
    normal (default) — will allow it to play over and over
    

(or)

For Mozilla Suite/SeaMonkey, under "Privacy & Security -> Images", make sure that "Accept all images" is selected.

Also, under "Advanced -> Scripts & Plugins", make sure that "Enable JavaScript for" "Navigator" (or "Browser") is checked and make sure that, under "Allow scripts to:", a checkmark is included next to "Change images".

share|improve this answer
1  
The OP states that he's change the mode back to normal. –  ChrisF Nov 11 '09 at 20:13
    
Yes, that does not work. –  David R Tribble Nov 11 '09 at 20:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.