Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to make wifi work under my Windows 7.

My computer has dual system: Windows 7 and Ubuntu. Under Ubuntu, the wifi works well, the setting of the proxy is None: enter image description here

However, Under Windows 7, the following setting does NOT work: enter image description here

Sorry for the Chinese characters, the main idea is all the boxes for the proxy have been unchecked. But it gives this error when I load a web page:

enter image description here

Besides, the wifi itself doesn't have any problem. Here is a screenshot:

enter image description here

Could anyone help?

Edit: Following the comment of @DaJF, I did some tests:

1) ping works well 2) nslookup www.kuhao360.com does NOT work

Here is the screenshot of ipconfig/all under Windows (sorry for Chinese characters again): enter image description here enter image description here enter image description here and ipconfig under Ubuntu: enter image description here

share|improve this question
    
ERR_NAME_NOT_RESOLVED points to a DNS issue. –  Brian Dec 22 '13 at 1:23
    
please see my update... –  SoftTimur Dec 22 '13 at 19:30

2 Answers 2

up vote 0 down vote accepted

Open the commandline in windows (Win+R, then type "cmd" and hit enter)

  • Can you ping? Type ping 110.249.215.46 (this is the IP address of kuhau360.com) and hit enter. Does this give you "Reply from 8.8.8.8: bytes=32 time=30ms TTL=50"? (bytes, time and TTL are most likely different) No? Report back with a screenshot of the output, and of ipconfig/all in windows, and ifconfig in ubuntu. Else, continue.
  • Is DNS correctly configured? Type ipconfig/flushdns to flush your cache. This is not really necessary, but this makes sure any subsequent dns-requests aren't read from the cache.
    Next, type nslookup www.kuhao360.com. If this doesn't give you an IP address, there's something wrong with the way windows tries to look it up. Please report back with a output from both ipconfig/all in windows, and ifconfig in ubuntu, so that they can be compared.

Ok, so there appears to be nothing wrong with your connection, which is what I expected. I see that you're using servers in france (89.2.0.1) for dns. Did you configure this?
Anyway, you can set your dns servers to what your router gives you by typing Win+R, and entering ncpa.cpl and hitting enter. This opens your Network Connections Panel (I'm guessing ncpa.cpl stands for 'networkconnectionspanel.controlpanel).
Now find the one that says Intel (R) WiFi Link 5100 AGN like below:
(I happen to have the same one in my laptop.)
Network_Connections
Right-click it, and select "Properties". Now select Internet Protocol Version 4 (TCP/IPv4) and click "Properties", like below:
Wireless_Connection
Then make sure yours looks like the one below, both "Obtain ... address automatically" selected:
DHCP_Setting
Click "Ok". Close the Intel (R) WiFi Link 5100 AGN dialog too. This should fix it. You might have to close your browser and reopen it for it to take effect.

share|improve this answer
    
Thank you for your comment, please see my update... –  SoftTimur Dec 22 '13 at 19:29
    
I've updated my answer as well. Hope I helped. –  DaJF Dec 22 '13 at 23:00
    
That works... thank you very much –  SoftTimur Dec 23 '13 at 21:14

Check your proxy settings in the browser you are using. In IE - Internet options->connections-> Lan settings In FF -Tools->Options->Advance->Network->Connection

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.