Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

While traveling in Lao PDR, I've subscribed to an unlimited cellular data plan (at Lao Telecom) because I have to maintain some websites during my trip. Everything works fine (connection is even pretty fast) but I would like to be able to use an outgoing SMTP server for some reasons related to a bug I encounter in one of these websites.

I can obtain SSH access and was used to connect to the french Free ISP outgoing SMTP server habitually, but this one requires to be under a Free connection.

share|improve this question

migrated from Dec 22 '13 at 4:33

This question came from our site for road warriors and seasoned travelers.

I think it is off-topic here. But why are you asking? Did you test whether it works? – Bernhard Dec 20 '13 at 13:52
This question appears to be off-topic because it is about SamTap – user165733 Dec 20 '13 at 14:14
I think this is a good question but it's not a travel question. I'm not sure if it belongs on SuperUser, ServerFault, or StackOverflow. I would tend toward SuperUser because I use it for questions vaguely similar. – hippietrail Dec 21 '13 at 3:23
Do you need to be able to use an outgoing SMTP server that is physically inside the country of Laos, or has a *.la DNS/rDNS, or has a Lao Telecom IP, or do you just need to be able to access ANY outgoing SMTP server from your connection? – K.A Dec 22 '13 at 4:38
@K.A : I need to be able to access any outgoing SMTP server from my connection. For example, in France, I use, that can be accessed only when you are connected to the Free ISP. – smonff Dec 22 '13 at 8:53
up vote 1 down vote accepted

prerequisites - if the following is true:

  1. you want the computer with which you are connecting to be able to connect a specific port on a destination host: farhost:farport
  2. the farhost:farport is unreachable - you did check with a simple tcp connect (using telnet or other means trying to establish a connection)
  3. you can configure the software that wants to connect to farhost:farport to connect to localhost:localport
  4. you can establish a SSH connection to a "known good" host on the internet (goodhost), that can connect to farhost:farport

then a possible solution is to run SSH on your local computer, forwarding a port on localhost over the SSH connection via the "known good" host to the far host, for example

ssh -L localport:farhost:farport goodhost

and to configure the application to connect to localhost:localport

share|improve this answer
It seems to be very simple now you've explained how to deal with it. Thanx – smonff Dec 26 '13 at 1:40
:-) but wait, there's more - check out SSH option -D to fake a SOCKS firewall, tunneling most of your network traffice over the SSH connection – Florenz Kley Dec 28 '13 at 17:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .