Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have checked the "Ask where to save each file before downloading" option in Chrome settings yet after installing 7-Zip, every time I click on a link which targets a .zip file:

  1. chrome doesn't fire up the download bar like with any other file type
  2. yet downloading starts automatically
  3. (which leaves me no chance to cancel the download for smaller files which arrive pretty fast)
  4. .zip file is saved to my default downloads folder
  5. 7-Zip fires up and opens the file

I can't find an option to disable this behaviour under the options of 7-zip nor Chrome. Having a file automatically downloaded and opened rises an obvious security concern. Has anyone ran into this before or knows a solution?

On last check:

  • Windows 7 Enterprise 64-bit
  • Google Chrome Version 31.0.1650.63
  • 7-Zip 9.20
share|improve this question
    
I'm just curious, instead of clicking it, does right-clicking it and selecting "Save link as.." open the file after download as well? –  DaJF Dec 23 '13 at 0:10
    
Apparently "Save link as..." option does allow to choose the location but after the download 7-Zip opens it automatically. –  Jaak Kütt Dec 23 '13 at 8:03
    
Then apparently the auto-open setting is universal, good thing @Dennis has a solution. –  DaJF Dec 23 '13 at 18:14
add comment

1 Answer

up vote 18 down vote accepted

There's nothing you can do in 7-Zip to prevent this. It is Chrome who downloads the file and opens it with its default application.

At some point, Chrome was instructed to open ZIP files automatically after downloading. THis overrides the Ask where to save each file before downloading setting.

There are at least three ways to revert this change:

  • Open chrome://settings/, locate the Downloads section and click Clear auto-opening settings.

    This will cause Chrome to forget the auto-opening settings for all file extensions.

  • Start downloading a ZIP file (e.g., http://www.oneasiahost.com/speedtest/100mb.zip) big enough to make the download bar visible for a few seconds.

    When the download bar appears, right-click the ongoing download and uncheck the option Always Open Files of This Type.

    You can cancel the download afterwards.

  • Close Chrome, open the folder %APPDATA%\Local\Google\Chrome\User Data in Windows Explorer, enter your profile's folder (usually Default) and edit the file Preferences.

    Search a line looking like

    "extensions_to_open": "zip",
    

    and remove the zip extension from the list.

    Save the changes and restart Chrome.

share|improve this answer
    
Would give another +1 for the pref file refrence. For the auto-opening settings - the "clear all" and "after downloading" parts of the explanation label kept me initially away from concidering that as a reasonable suspect. –  Jaak Kütt Dec 22 '13 at 15:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.