Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

For some time now when I click Open with from Windows Explorer's context menu I'm getting this error

This file does not have a program associated with it to perform this action. Create an association in the Set Associations control panel.

instead of the standard Choose Default Program dialog. I'm getting this error no matter what the extension of the selected file is (as long as there's Open with option for given extension; some extensions do not show this option). How can I fix this?

share|improve this question

3 Answers 3

Check files associations settings

Control Panel -> Default Programs -> Set Files Associations

There you can edit associations for each file type

share|improve this answer
    
You missed the point. The problem is I don't get the standard Choose Default Program dialog for files with unknown (not associated) extensions. –  Piotr Dobrogost May 16 '10 at 10:02

Thanks alot. For me the answere was working. Your problem is a missing key in the registration. There is a articel on the microsoft support website for this case, but no fix. I think you need to make a clean reinstall or write your own key into the reg.

share|improve this answer

This article didn't tell me exactly how to fix it but it gave me an idea:

http://support.microsoft.com/kb/218805

It said to examine the following registry key:

HKEY_CLASSES_ROOT\Unknown\shell\openas\command

And it said to look at the following default value:

C:\%windir%\rundll32.exe shell32.dll,OpenAs_RunDLL %1 
share|improve this answer
2  
And then what did you do? –  Isaac Rabinovitch Dec 2 '12 at 22:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.