Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

During boot, I get a series of messages like

modem-manager: ... 
modem-manager: ...

I tried disabling this feature with

sudo update-rc.d -f remove modem-manager remove

EDIT: The output I got is

Removing any system startup links for /etc/init.d/modemmanager ...

And I didnt receive any output that seem to disable the links to the actual service.

And further I tried disabling the lightdm service at runtime, with:

sudo update-rc.d -f lightdm remove

Neither of these seem to have any effect when I reboot the system. Am i missing something? thank you, in advance.

share|improve this question
What distribution is this? (Also add a tag for it, if you don't mind.) – Bandrami Dec 23 '13 at 6:12

1 Answer 1

up vote 2 down vote accepted

Ubuntu 12.10 should be using upstart, not SysV. Try

sudo sh -c 'echo manual >> /etc/init/modemmanager.override'

or for lightdm

sudo sh -C 'echo manual >> /etc/init/lightdm.override'

(Note that this last one will keep you from having a graphical login; you probably know that but just in case...)

share|improve this answer
Thanks, it worked. I simply removed the *.override file, to start the service again, this would do? isnt it? – Vigneshwaren Dec 23 '13 at 6:43
Yeah, though check and make sure there wasn't already other stuff in the override file (I doubt it, but just in case). If there was other stuff than "manual", just edit the override file and remove the line that says "manual" to get it back. – Bandrami Dec 23 '13 at 6:44
Thanks, great, awesome. It worked. – Vigneshwaren Dec 23 '13 at 6:45

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.