Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Whenever I dock my laptop onto my docking station, Windows disables my Wireless Network Connection and enables my Wired Network Connection. Whenever I undock my laptop, Windows disables my Wired Network Connection and enables my Wireless Network Connection.

Is there a way to disable this feature?

After Windows performs the automatic disabling/enabling, I run into errors when I try to disable the now-enabled connection, specifically "It is not possible to disable the connection at this time. This connection may be using one or more protocols that do not support Plug-and-Play, or it may have been initiated by another user or the system account."

I'm assuming the latter portion of the error is true ... my network connections are being enabled/disabled under a system account. Regardless, I'd just like to disable the feature altogether.

For reference, I'm working with Windows XP Professional on a Dell Latitude D630.

share|improve this question

Go to Microsoft support. There is a hotfix. This is a known issue.;en-us;959267&sd=rss&spid=3223

share|improve this answer
Corrected link:… – JC. Feb 16 '11 at 15:34

I had the same problem with an Lenovo laptop/docking station. The fix is to keep the same network connection in either mode, which really means not using the dock's network connection. I did this be deleting the "1394 Connection", which is the network connection used by my dock.

share|improve this answer

Go to system bios there is an option for LAN\WLAN swtiching. Disable that optiona and you should be all set.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.