Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Windows 7.

If I delete something from the desktop, then the icon remains there.

I have to hit F5 or right-click->Refresh to make the desktop refresh. After the refresh, the icon disappears.

Any suggestions?

share|improve this question
    
(Can't post as answer due rep) Go to: (Explorer) Folder Options > Search tab and check or uncheck some of the options. Pretty stupid bug. –  pileofrocks Jul 4 '14 at 18:04

3 Answers 3

I finally found the answer to this...

Open regedit and search for dontrefresh.

You should find a value that has dontrefresh set to 1. Change this value to 0 and your problem should be solved.

I found the value under HKEY_CLASSES_ROOT\CLSID\{BDEADE7F-C265-11D0-BCED-00A0C90AB50F}\Instance

I confirmed the fix on my laptop. No more pressing F5 after I make a new folder or move a file to my desktop!

share|improve this answer
    
Unfortunately, dontrefresh does not exist in my registry (according to the commens here, neither does on many other computers). I could obviously create it, but hard to to tell under what path it should be made. –  pileofrocks Jul 4 '14 at 17:59

Temporary AutoHotkey fix:

While 1
{
    IfWinExist Confirm File Delete ahk_class #32770
    {
    	WinWaitClose, Confirm File Delete ahk_class #32770
    	ControlSend,,{F5},ahk_class Progman
    }
    Sleep 1
}

Explaination:

If the confirm file delete dialog is open, wait until it's closed then send F5 to the desktop. I know this will always refresh the desktop even if the file wasn't deleted from the desktop, but it doesn't hurt anything really.

share|improve this answer
    
Shouldn't it be "$Del::" , as you send {Del} itself in the script? –  Snark Nov 11 '09 at 22:12
    
last approach was bad anyways, changed it all around. –  John T Nov 11 '09 at 22:27
1  
Shouldn't that have a While, 1 in there, in case the OP wants to delete more than one file? ;) –  Phoshi Nov 11 '09 at 22:31
    
knew I was missing something, thank you! –  John T Nov 11 '09 at 22:42

I have solved the problem by removing the CPU clock from the side bar, this tool caused the problem and also didn't allow the machine to shut down properly.

If that is not the case, think about an application that you have installed recently that might cause this fault and remove it.

share|improve this answer
    
Thanks for the tip, but I have the sidebar completely turned off. –  JosephStyons Nov 24 '09 at 17:06
    
Just about any 3rd party utility or extension can cause this in the same manner, so this is a good answer to consider, even if you don't have this specific utility. –  Ƭᴇcʜιᴇ007 Sep 25 '13 at 20:45

protected by Diago Nov 26 '10 at 10:02

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.