Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Windows Update keeps telling me that I have 5 (put your random number here) important updates to install. However, when I click on them, the list that pops up is empty. I can still install the updates, but I cannot see and of course also not decide which updates are going to be installed.

share|improve this question
1  
I have the same problem with Windows Vista. Sometimes goes away after a reboot, but not fun at all. –  AKX Apr 20 '10 at 18:38
    
Did you ever solve this? I tried superuser.com/questions/123623/… and some other things, but still the same problem. Thanks –  splattne Feb 7 '11 at 15:32
    
I have exactly the same problem, both on my laptop, and my work computer (home office). This answer from Noah does not solve it. –  awe May 27 '11 at 7:22

2 Answers 2

up vote 0 down vote accepted

I have found that Microsoft Support are very good at these type of problems which go to the core of their operating system. I would email them, or even phone them if they supply a freephone number for your area.

I have to admit that such calls go one of two ways, you are either stunned how easy and efficient they are, or it's a nightmare of holding redirecting, in which case I would just hang up.

share|improve this answer
    
Thank you. Not the answer I expected, but helpful, too ;) I'll report back. –  Franz Nov 11 '09 at 22:41
    
I would vote you up, if I could ;) –  Franz Nov 11 '09 at 22:56
    
What in the world? They don't even accept my product ID! Probably because it's OEM and you can forget the support at the computer manufacturer... –  Franz Nov 11 '09 at 22:57

This can occur from a corruption in the Cryptographic service database log

The following steps will delete the log, which will be automatically rebuilt as needed

Click the Start 
type cmd in the Search all programs 
right click cmd.exe, click Run as administrator, Agree to the UAC prompt

At the command prompt, type the following commands:
      net stop cryptsvc
      ren %systemroot%\system32\catroot2\edb.log *.tst
      net start cryptsvc
      exit 

After every is working again, go ahead and delete the edb.tst file

share|improve this answer
    
did not solve the problem for me. –  splattne Feb 7 '11 at 15:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.